bugGnash - The GNU Flash player - Bugs: bug #37590, GCC 4.7 and ::getpid in...

 
 

bug #37590: GCC 4.7 and ::getpid in klash_part.cpp

Submitted by:  None
Submitted on:  Wed 17 Oct 2012 07:31:52 PM UTC  
 
Category: gui-kde4Severity: 3 - Normal
Release: NoneStatus: Ready For Test
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Fri 26 Oct 2012 03:12:08 PM UTC, comment #7:

With GCC 4.8, it compiles just fine with a fresh checkout of master. Haven't tried 4.7.

Rob Savoye <rsavoye>
Project Administrator
Fri 26 Oct 2012 01:51:24 PM UTC, comment #6:

I take it it's still necessary to include extend 39fcd513 to klash/ ?

Bastiaan Jacques <bjacques>
Project Member
Fri 26 Oct 2012 01:44:12 PM UTC, comment #5:

You're right.
I pushed a revert in 1db6444f8092e0daadc04bd392cd372d4e0a011e

Sandro Santilli <strk>
Project Member
Fri 26 Oct 2012 01:38:45 PM UTC, comment #4:

A fresh 'git pull' shows the change wasn't reverted. All 544ff9c0 did was revert the boost change for the system library.

Rob Savoye <rsavoye>
Project Administrator
Fri 26 Oct 2012 09:50:30 AM UTC, comment #3:

The commit was reverted with 544ff9c0, after Bastiaan mentioned that the support for GCC 3.4 should have been supposedly already fixed by 39fcd513 (with including "GnashSystemIOHeaders.h" in klash4/klash_part.cpp)

Maybe the same fix should be done for klash/klash_part.cpp,
but I don't have the required setup to test it

Sandro Santilli <strk>
Project Member
Fri 26 Oct 2012 03:21:45 AM UTC, comment #2:

This breaks building the klash4 plugin with GCC 4.6 and older. If you change cunistd to unistd.h, it builds with GCC 4.6 and GCC 4.8.

Rob Savoye <rsavoye>
Project Administrator
Wed 17 Oct 2012 08:27:53 PM UTC, comment #1:

Please try with 5cc3e72

Sandro Santilli <strk>
Project Member
Wed 17 Oct 2012 07:31:52 PM UTC, original submission:

This applies to both klash and klash4 plugins: Would it be possible to #include <unistd.h> in klash_part.cpp for compatibility with GCC 4.7?

According to http://gcc.gnu.org/gcc-4.7/changes.html it is no longer included automatically.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bjacques (Posted a comment)
  • -unavailable- added by strk (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 26 Oct 2012 01:51:57 PM UTCstrkStatusNone=>Ready For Test
      Assigned tostrk=>None
    Fri 26 Oct 2012 01:51:24 PM UTCbjacquesStatusReady For Test=>None
    Wed 17 Oct 2012 08:27:53 PM UTCstrkStatusNone=>Ready For Test
      Assigned toNone=>strk

    Back to the top


    Powered by Savane 3.1-cleanup