bugLiquid War 6 - Bugs: bug #35346, make dist error

 
 

bug #35346: make dist error

Submitted by:  Andrew Engelbrecht <sudoman>
Submitted on:  Sat 21 Jan 2012 03:58:07 PM UTC  
 
Category: InstallSeverity: 3 - Normal
Status: ConfirmedPrivacy: Public
Assigned to: Christian Mauduit <ufoot>Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 21 Jan 2012 08:44:58 PM UTC, comment #1:

mmm, I've had this one some time ago.

I see you run ../configure and not ./configure and this is confirmed by the path "liquidwar6/build/doc".

I've had the exact problem you're having some time ago, make dist would not work when not building in "." (that's to say runnning ./configure). I acknownledge this is not recommend for GNU packages, and BTW I do always use a different directory to build than the one I use to checkout the source.

But some day it got broken, I think that was after some system update, at that time I suspected it was related to an automake/autoconf update. But I might as well have broken something along the road or just put it wrong from start. LW6 doc is a mix of auto-generated stuff and manually edited files. For some reason it now works again, AFAIK I did not check wether I had fixed something or wether a subsequent update of autotools fixed the problem. It got solved by magic on my box :-/ I use Debian wheezy.

My suggestion is you try the latest snapshot on http://www.ufoot.org/liquidwar/v6/snapshots/ see what you get. If it's no better, then try ./configure instead of ../configure. Then I guess the problem is rather on autotools but then, they probably have already fixed it if the problem was on their side.

Have a nice day,

Christian.

Christian Mauduit <ufoot>
Project AdministratorIn charge of this item.
Sat 21 Jan 2012 03:58:07 PM UTC, original submission:

I get this error after running ../configure and make dist:

make[1]: Entering directory `/home/sudoman/src/liquidwar6/liquidwar6/build/doc'
echo gdoc && cd ../../doc && /bin/bash /home/sudoman/src/liquidwar6/liquidwar6/missing --run perl ../../doc/gdoc.pl -texinfo ../../src/lib/lw6-callback.c ../../src/lib/lw6-control.c ../../src/lib/lw6-fix.c ../../src/lib/lw6-funcs.c ../../src/lib/lw6-global.c ../../src/lib/lw6-main.c ../../src/lib/lw6-options.c ../../src/lib/lw6-print.c ../../src/lib/lw6-smobs.c ../../src/lib/lw6-test.c ../../src/lib/lw6-testmain.c > ../../doc/liquidwar6-gdoc.texi
gdoc
/bin/bash: ../../doc/liquidwar6-gdoc.texi: No such file or directory
make[1]: *** [../../doc/liquidwar6-gdoc.texi] Error 1
make[1]: Leaving directory `/home/sudoman/src/liquidwar6/liquidwar6/build/doc'
make: *** [distdir] Error 1

It looks like the file is actually there... so I don't know what's going wrong.

sudoman@igo doc$ pwd
/home/sudoman/src/liquidwar6/liquidwar6/build/doc
sudoman@igo doc$ ls ../../doc/liquidwar6-gdoc.texi
../../doc/liquidwar6-gdoc.texi

Running autoreconf then trying again didn't fix the issue for me.

Andrew Engelbrecht <sudoman>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by ufoot (Posted a comment)
  • -unavailable- added by sudoman (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 21 Jan 2012 08:45:14 PM UTCufootStatusNone=>Confirmed
    Sat 21 Jan 2012 08:44:58 PM UTCufootAssigned toNone=>ufoot

    Back to the top


    Powered by Savane 3.1-cleanup