bugGnash - The GNU Flash player - Bugs: bug #35300, A regular compilation fails in...

 
 

bug #35300: A regular compilation fails in Debian testing

Submitted by:  Davide Baldini <davide>
Submitted on:  Thu 12 Jan 2012 11:28:55 PM UTC  
 
Category: buildSeverity: 3 - Normal
Release: 0.8.9Status: Ready For Test
Privacy: PublicAssigned to: Rob Savoye <rsavoye>
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 25 Jan 2012 10:06:03 PM UTC, comment #16:

This is fixed as of commit #4c6b960. Yes, very recently the output of 'sdl-config --libs' changed, my original chroot of wheezy had it the old way, but updating I got the new version, and reproduced this. I migrated this patch to the upcoming release as well.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Wed 25 Jan 2012 06:14:35 PM UTC, comment #15:

Yes, tested on wheezy a couple of days ago. It became a problem after a recent Debian package update, I believe.

Benjamin Wolsey <bwy>
Project Member
Wed 25 Jan 2012 04:27:58 AM UTC, comment #14:

You tested this on wheezy ? I did too, but didn't see this problem, so would like to be able to reproduce it. SDL is used for sound, so we're stuck with it. /usr/lib is trimmed out as it should be in the default path for the compiler, and leaving it in breaks cross compiling.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Tue 24 Jan 2012 08:01:16 PM UTC, comment #13:

I can confirm this; macros/sdl.m4 trims /usr/lib from the output of sdl-config, which causes an incorrect argument to be passed to the linker.

SDL is also linked with the GTK GUI, so omitting the SDL GUI won't help (not that it's a solution to the problem anyway!).

Benjamin Wolsey <bwy>
Project Member
Tue 24 Jan 2012 12:48:09 AM UTC, comment #12:

So I've been building git master on wheezy with no problems, so I'm wondering if there is something weird going on on your end. Do you have SDL installed ? You can try configuring with --enable-gui=gtk to drop SDL from the build. Also, ;make dumpconfig' will dump all the settings configure found to the terminal.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Mon 23 Jan 2012 12:59:28 PM UTC, comment #11:

I made a final test with 0.8.9:
NPAPI_CONST in gnashconfig.h wasn't defined nor commented out. I appended the line '#define NPAPI_CONST' but the outcome was the same as of comment #9.

Then I downloaded the git repository of yesterday and tried with it:
gnashconfig.h autonomously defines HAVE_PTHREADS and NPAPI_CONST (set to '1'); the compilation completes, and the software works!

Additionally, I compiled the git snapshot on another system which is entirely debian testing: here, make fails ending with:

CXXLD sdl-gnash
g++: error: /i386-linux-gnu: No such file or directory
make[4]: *** [sdl-gnash] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/home/davide/gnash/gnash-git/gui'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/davide/gnash/gnash-git/gui'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/davide/gnash/gnash-git/gui'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/davide/gnash/gnash-git'
make: *** [all] Error 2

Davide Baldini <davide>
Sun 15 Jan 2012 02:56:53 AM UTC, comment #10:

I installed a wheezy chroot, and Gnash configured and built correctly. I was using master, but also didn't need any patch.
Is NPAPI_CONST enabled in gnashconfig.h ? This also built fine for me with wheezy. I haven't tested this with the 0.8.9 release, as a new release will be out soon.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sat 14 Jan 2012 04:42:11 PM UTC, comment #9:

A further compile trouble I'm encountering with 0.8.9 (w/o Gabriele's patch) even after correcting the HAVE_PTHREADS in gnashconfig.h, is:

CXX libgnashplugin_la-np_entry.lo
mozilla-sdk/np_entry.cpp:241:33: error: new declaration 'char* NP_GetMIMEDescription()'

./configure is run as

./configure --prefix=/usr/handsoftware/ --enable-media=gst --enable-hwaccel=vaapi CFLAGS='-march=core2 -O2' CXXFLAGS='-march=core2 -O2'

I've attached full output.

--Davide

Davide Baldini <davide>
Sat 14 Jan 2012 04:37:58 PM UTC, comment #8:

Gabriele, the patch doesn't apply fully:

davide@RAM:~/Download/gnash-0.8.9$ patch -p1 < p
patching file configure.ac
Hunk #1 succeeded at 517 (offset 13 lines).
patching file macros/libslist
Reversed (or previously applied) patch detected! Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file macros/libslist.rej

After patching the result is the same.

Davide Baldini <davide>
Sat 14 Jan 2012 04:07:40 PM UTC, comment #7:

Probably applying this one [1] would fix the build.

[0] http://deb.li/p6V

questions: - why building 0.8.9 on debian testing instead of current debian version 0.8.10~git20111001-1 (or previous one from snapshot.debian.org 0.8.10~git20110618-3) or a snapshot from git repository ($ git clone git://git.sv.gnu.org/gnash.git)?
- did anyone remove gnash-commit@ from Carbon-Copy list or has it never been CC'ed if Category=build, Release=0.8.9?

Gabriele Giacone <gg0>
Project Member
Sat 14 Jan 2012 03:25:55 PM UTC, comment #6:

I haven't figured out what tests are required.
I'd follow your instructions, or if you prefer I can open a ssh when you want.
I'll send you now my contact.

Davide Baldini <davide>
Sat 14 Jan 2012 03:12:57 PM UTC, comment #5:

It looks like with Debian testing, the location of libpthread has changed. It should have been found in /usr/lib/i386-linux-gnu, but unless you can do some remote testing for me, I'll need to install Debian testing first to see what's up.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sat 14 Jan 2012 03:06:22 PM UTC, comment #4:

A complete search on filesystem shows:

davide@RAM:/$ find 2>/dev/null | grep 'libpthread\.so'
./lib/i386-linux-gnu/i686/cmov/libpthread.so.0
./lib/i386-linux-gnu/libpthread.so.0
./usr/lib/i386-linux-gnu/libpthread.so

davide@RAM:/$ find 2>/dev/null | grep 'pthread\.h'
./usr/include/pthread.h

These paths have been handled only by APT.

--Davide

Davide Baldini <davide>
Sat 14 Jan 2012 02:40:55 PM UTC, comment #3:

Do you have /usr/include/pthread.h and /usr/lib/libpthread.so ? That's where configure looks for the pthread support.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sat 14 Jan 2012 12:54:51 PM UTC, comment #2:

I checked pthread.h; it does define PTHREAD_ADAPTIVE_MUTEX_INITIALIZER_NP and
PTHREAD_MUTEX_ADAPTIVE_NP. However, in gnashconfig.h the #define for HAVE_PTHREADS was commented out and switched to #undef. Correcting this, it works!

--Davide

Davide Baldini <davide>
Fri 13 Jan 2012 05:35:17 PM UTC, comment #1:

You can ignore all the WARNINGs from configure, they're only used to run the testsuite. You can eliminate those warnings by configuring with --disable-testsuite.

Now the build error with PTHREAD_ADAPTIVE_MUTEX_INITIALIZER_NP and
PTHREAD_MUTEX_ADAPTIVE_NP not being found is more interesting. I did squeeze builds yesterday, so I know it builds there. They should be defined in pthread.h. Maybe installing a mix of files is causing a problem, but gnashconfig,h should have HAVE_PTHREADS enabled.

At this link, http://wiki.gnashdev.org/Debugging_Autotools_issues, there is much more info on how to track down what is going on.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Thu 12 Jan 2012 11:28:55 PM UTC, original submission:

Most of system packages came from Debian squeeze repository; a minor part of them are from Debian testing, especially all those demanded or recommended by Gnash's ./configure.

Full output (stdout / stderr) of 'configure' and 'make' is attached.

Thank you.

--Davide

Davide Baldini <davide>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #24819:  make_output_NP_GetMIMEDescription added by davide (26kB - application/octet-stream)
file #24809:  configure_output added by davide (31kB - application/octet-stream)
file #24810:  make_output added by davide (4kB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bwy (Posted a comment)
  • -unavailable- added by gg0 (Posted a comment)
  • -unavailable- added by rsavoye (Updated the item)
  • -unavailable- added by davide (Submitted the item)
  • -unavailable- added by davide
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 25 Jan 2012 10:06:03 PM UTCrsavoyeStatusIn Progress=>Ready For Test
    Sat 14 Jan 2012 04:44:25 PM UTCdavideAttached File-=>Added make_output_NP_GetMIMEDescription, #24819
    Sat 14 Jan 2012 03:12:57 PM UTCrsavoyeStatusNeed Info=>In Progress
    Fri 13 Jan 2012 05:35:17 PM UTCrsavoyeStatusNone=>Need Info
      Assigned toNone=>rsavoye
    Thu 12 Jan 2012 11:28:55 PM UTCdavideAttached File-=>Added configure_output, #24809
      Attached File-=>Added make_output, #24810
      Carbon-Copy-=>Added davide

    Back to the top


    Powered by Savane 3.1-cleanup