bugGNUstep - Bugs: bug #34933, Gorm svn is unable to link...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #34933: Gorm svn is unable to link Palettes and Plugins

Submitted by:  Sebastian Reitenbach <buzzdee>
Submitted on:  Tue 29 Nov 2011 01:13:54 PM UTC  
 
Category: GormSeverity: 3 - Normal
Item Group: InstallationStatus: Fixed
Privacy: PublicAssigned to: None
Open/Closed: Closed

Tue 29 Nov 2011 01:13:54 PM UTC, original submission:

Hi,

I noticed, trying to compile Gorm from svn, it doesn't link anymore, when an older version of Gorm is not (yet) installed, at least for me on OpenBSD.

The problem happens to materialize for all subdirectories in the Palettes and Plugins directories.

Copying the following stuff out of the conditionals for the windows platforms, makes it work again for me:

ADDITIONAL_LIB_DIRS += \
-L../../GormLib/$(GNUSTEP_OBJ_DIR) \
-L../../GormObjCHeaderParser/$(GNUSTEP_OBJ_DIR) \
-L../../GormPrefs/$(GNUSTEP_OBJ_DIR) \
-L../../GormCore/$(GNUSTEP_OBJ_DIR)

The other stuff in the conditonals don't seem to be needed.

Sebastian

Sebastian Reitenbach <buzzdee>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by gcasa (Updated the item)
  • -unavailable- added by buzzdee (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 05 Mar 2013 11:35:07 PM UTCgcasaStatusNone=>Fixed
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup