bugGNU nano - Bugs: bug #32552, Three Mouse Clicks Needed Before...

 
 

bug #32552: Three Mouse Clicks Needed Before Mouse Works

Submitted by:  None
Submitted on:  Mon 21 Feb 2011 06:47:46 AM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: In Progress
Privacy: PublicAssigned to: Chris Allegretta <astyanax>
Open/Closed: OpenRelease: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Thu 26 Dec 2013 04:04:15 AM UTC, comment #6:

Hmm, I see what you mean now that I tried out a similar setup. What seems to be happening is that ncurses is sending back MOUSE1_PRESSED some times, which means we're not getting normal events back from the mouse handler. I did try to work around this, but this led to some very undesirable behavior. So the bug is either in putty's xterm mouse events, or ncurses' handling of them. Unsure which it is, but I'll try some more experimentation.

Chris Allegretta <astyanax>
Project AdministratorIn charge of this item.
Sun 22 Dec 2013 12:37:46 AM UTC, comment #5:

Hi Chris -- thanks so much for the response, and so sorry for the delay on my part! I am generating mouse events by opening a PuTTY terminal in Windows, logging on to my server, starting nano, and clicking on text. That used to work fine, but it's still broken as of now (version 2.3.1 running on Debian Wheezy). Thanks!

Anonymous
Sat 12 Jan 2013 03:10:36 AM UTC, comment #4:

Hello,

Thank you for the report, and sorry for the delayed response.

Im curious how you're generating mouse events if you are not using gpm or X. Can you please give more details.

Chris Allegretta <astyanax>
Project AdministratorIn charge of this item.
Thu 10 Jan 2013 04:49:05 PM UTC, comment #3:

I'm the OP. I'm pretty disappointed it's been a year and nobody ever responded to me. This reflects very poorly on nano. It's hard to recommend nano to people when it appears development and support have ended.

Anonymous
Fri 01 Apr 2011 09:53:30 PM UTC, comment #2:

Message from OP: The problem persists in Nano 2.3.0.

Anonymous
Mon 21 Feb 2011 06:50:35 AM UTC, comment #1:

Message from OP:

PS, for these tests, I don't have a nanorc present. I'm invoking nano only with the "-m" option.

Anonymous
Mon 21 Feb 2011 06:47:46 AM UTC, original submission:

Hi, the following problem seems to be in nano version 2.2.6. It's unclear to me if earlier versions have this problem as well.

I have two servers that are exactly alike except one runs Debian Lenny and the other runs Debian Squeeze. Admittedly, that's a pretty big difference, because a lot of things changed in between those versions.

In any event, on Debian Lenny, the mouse works perfectly. In Debian Squeeze, the mouse only works after you click it three times subsequent to opening a file. Once you've clicked three times, the mouse works pretty well, but I swear the mouse is less responsive, as in sometimes clicks get "lost."

I am trying to use the mouse through SSH. I have a very minimal installation that does not have X or gpm installed on it. Another application that uses the mouse, w3m, works perfectly. So I think there's good reason to believe that something is wrong with nano or my environment for running nano.

Thanks!

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by astyanax (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 26 Dec 2013 04:04:15 AM UTCastyanaxStatusNeed Info=>In Progress
    Sat 12 Jan 2013 03:10:36 AM UTCastyanaxStatusNone=>Need Info
      Assigned toNone=>astyanax

    Back to the top


    Powered by Savane 3.1-cleanup