bugGNU Anubis - Bugs: bug #26851, anubis uses libgnutls-config to...

 
 

bug #26851: anubis uses libgnutls-config to locate gnutls

Submitted by:  Andreas Metzler <ametzler>
Submitted on:  Sat 20 Jun 2009 09:36:06 AM UTC  
 
Category: compilationSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 21 Jun 2009 12:18:45 PM UTC, comment #5:

Thank's for checking.

Andreas Metzler <ametzler>
Sun 21 Jun 2009 12:00:51 PM UTC, comment #4:

It didn't fail. I build it using pbuilder with --without-gnutls and Build-Depends: reduced to debhelper (>= 5), dpatch, autotools-dev, m4.

Krzysztof Burghardt <burghardt>
Project Member
Sun 21 Jun 2009 10:46:32 AM UTC, comment #3:

Hmm. do you think PKG_PROG_PKG_CONFIG is necessary because PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0]
is wraopped in an if clause?

But won't this cause ./configure to fail if with_gnutls=no is specified and pkg-config is not installed?

Andreas Metzler <ametzler>
Sun 21 Jun 2009 10:40:04 AM UTC, comment #2:

My manual page pkg-config(1), section AUTOCONF MACROS disagrees:
"Note that if there is a possibility the first call to PKG_CHECK_MODULES might not happen, you should be sure to include an explicit call to PKG_PROG_PKG_CONFIG in your configure.ac"

% dpkg -S pkg-config.1.gz
pkg-config: /usr/share/man/man1/pkg-config.1.gz
% dpkg -l pkg-config | tail -n1 | tr -s ' '
ii pkg-config 0.22-1 manage compile and link flags for libraries

Krzysztof Burghardt <burghardt>
Project Member
Sun 21 Jun 2009 10:32:09 AM UTC, comment #1:

Re patch: Adding PKG_PROG_PKG_CONFIG should not be necessary, PKG_CHECK_MODULES invokes it if necessary.

Andreas Metzler <ametzler>
Sat 20 Jun 2009 09:36:06 AM UTC, original submission:

anubis is using AM_PATH_LIBGNUTLS to locate gnutls library and headers. This macro and the script libgnutls-config that is used by it is deprecated and not part of gnutls stable releases 2.8.0 and later. Please switch to a different macro, the easiest and straightforward way is to simply go for
PKG_CHECK_MODULES.

http://bugs.debian.org/529901

cu andreas

Andreas Metzler <ametzler>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #18299:  anubis-4.1.1+dfsg1-gnutls-pkg-config.patch added by burghardt (763B - text/x-diff - Patch for configure.ac that detect gnutls using PKG_CHECK_MODULES.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by burghardt (Updated the item)
  • -unavailable- added by ametzler (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 21 Jun 2009 10:26:56 AM UTCburghardtAttached File-=>Added anubis-4.1.1+dfsg1-gnutls-pkg-config.patch, #18299

    Back to the top


    Powered by Savane 3.1-cleanup