bugGNUstep - Bugs: bug #26364, Menus on which are adjusted to...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #26364: Menus on which are adjusted to display on GNOME are not tracking properly...

Submitted by:  Gregory John Casamento <gcasa>
Submitted on:  Mon 27 Apr 2009 09:26:38 PM UTC  
 
Category: Gui/AppKitSeverity: 2 - Minor
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Sun 17 May 2009 05:08:01 AM UTC, comment #2:

Forgot to note: I'm using GNUstep SVN from 16/5/2009 for everything.

Chris Armstrong <carmstrong>
Sun 17 May 2009 05:06:52 AM UTC, comment #1:

I'm experiencing these issues with xfwm4 and SystemPreferences when I set NSInterfaceStyleDefault=NSWindows95InterfaceStyle:

1. Switch the focus from the SystemPreferences application to another (non-GNUstep) application.

The menu bar in the GNUstep application disappears. If I switch back, it re-appears.

2. Click on one of the menus to open it (e.g. "Edit"). Click on the same part of the horizontal menu bar again.

The menu doesn't close, it seems to get hidden behind the main window, and the menu bar is still highlighted.

I have to click on it another two times (why?) before it disappears. In the meantime, the rest of the application responds to my clicks.

3. Select Info->Hide, and the application hides.

Double-click on the App icon, and the main window is restored, but the drop-down part of the menu appears up in the top-left of the screen, and the application main window is missing its horizontal menu bar.

4. Click and hold mouse down on Info drop-down, move it down over a sub-menu (such as Services), and then move the mouse out of the window and then release over the top of another application.

The menu remains open, and I have to click the menu-bar twice to clean it up.

Chris Armstrong <carmstrong>
Mon 27 Apr 2009 09:26:38 PM UTC, original submission:

When you use a GNUstep application in a GNOME environment, it adjusts submenus down when they're opened. The mouse doesn't track correctly in the menu until you move the main part of the menu below the top menu bar on GNOME.

GC

Gregory John Casamento <gcasa>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by carmstrong (Posted a comment)
  • -unavailable- added by gcasa (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup