bugGNUstep - Bugs: bug #24886, after connecting objects in gorm,...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #24886: after connecting objects in gorm, the cursor stays the green arrow

Submitted by:  Sebastian Reitenbach <buzzdee>
Submitted on:  Thu 20 Nov 2008 06:36:05 AM UTC  
 
Category: Gui/AppKitSeverity: 3 - Normal
Item Group: BugStatus: Fixed
Privacy: PublicAssigned to: None
Open/Closed: Closed

(Jump to the original submission Jump to the original submission)

Sat 10 Jan 2009 06:50:24 AM UTC, comment #6:

as said, I cannot tell you which of the upgraded components fixed the problem, but it disappeared.

Sebastian Reitenbach <buzzdee>
Project Member
Fri 09 Jan 2009 06:49:03 PM UTC, comment #5:

Are you sure this issue is resolved for you? Then I will close this bug report.

Fred Kiefer <FredKiefer>
Project Member
Sun 28 Dec 2008 01:53:20 PM UTC, comment #4:

I updated to libffi-3.0.8, and to the following gnustep-packages, and the problem is gone:
gnustep-make-2.0.7
gnustep-base-1.18.0p0
gnustep-gui-0.16.0
gnustep-back-0.16.0

Sebastian Reitenbach <buzzdee>
Project Member
Wed 03 Dec 2008 01:13:07 AM UTC, comment #3:

I too think this is a back/gui problem since I experience a similar behaviour when drag/dropping items inside gworkspace

Riccardo Mottola <rmottola>
Project Member
Sun 30 Nov 2008 11:12:10 AM UTC, comment #2:

I had some time to recompile with -base linked against ffcall, but the problem is still there.

Sebastian Reitenbach <buzzdee>
Project Member
Sat 22 Nov 2008 02:52:42 PM UTC, comment #1:

I think this is rather a gui or back problem, as I get the same problem with other applications as well.
Not sure how this is happeniong, as we thought to have resolved all previous issues of that category before and I remember this working well for some time.

Fred Kiefer <FredKiefer>
Project Member
Thu 20 Nov 2008 06:36:05 AM UTC, original submission:

Hi,

not really sure, whether this is a gorm issue, or a -gui, or -backend, but at least I've observed it within gorm.
after connecting an outlet or action with sth. else in gorm, the cursor stays the green arrow when hovered over a gorm window.
When I move the cursor over the desktop or other window, then it becomes the ordinary arrow.
I'm on openbsd 4.4, i386.
gnustep-make-2.0.6
gnustep-base-1.16.5 (linked against libffi-3.0.7)
gnustep-gui-0.14.0
gnustep-back-0.14.0 (using art or xlib, doesn't matter)
gnustep-gorm-1.2.6
IIRC, the problem did not happen, when linking -base against ffcall instead of libffi.
I'll reinstall everything, linking against ffcall later today.

sebastian

Sebastian Reitenbach <buzzdee>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rmottola (Posted a comment)
  • -unavailable- added by FredKiefer (Posted a comment)
  • -unavailable- added by buzzdee (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 09 Jan 2009 06:49:03 PM UTCFredKieferStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Sat 22 Nov 2008 02:52:42 PM UTCFredKieferCategoryGorm=>Gui/AppKit

    Back to the top


    Powered by Savane 3.1-cleanup