bugGnash - The GNU Flash player - Bugs: bug #24649, AudioDecoderFfmpeg: could not...

 
 

bug #24649: AudioDecoderFfmpeg: could not initialize a parser for ffmpeg codec id 86021

Submitted by:  Sandro Santilli <strk>
Submitted on:  Sat 25 Oct 2008 05:00:42 PM UTC  
 
Category: video-ffmpegSeverity: 3 - Normal
Release: NoneStatus: Confirmed
Privacy: PublicAssigned to: Jonas 'Sortie' Termansen <sortie>
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 28 Jul 2011 12:52:02 PM UTC, comment #4:

Reassigning to sortie, who's working on refactoring of AudioDecoder interface.

Sandro Santilli <strk>
Project Member
Sun 20 Feb 2011 03:23:46 AM UTC, comment #3:

The synchronisation issue appears to be caused by the lack of timestamps provided by the container format of the input file. (Or, potentially, ffmpeg fails to recognise them.) Timestamps will therefore not be known prior to decoding, and after that could only be construed by counting samples provided by the decoder.

Playback synchronisation is presently dependent on the availability of accurate timestamps.

Bastiaan Jacques <bjacques>
Project Member
Sun 20 Feb 2011 02:58:13 AM UTC, comment #2:

There are two distinct issues here:

1. The AudioDecoderFfmpeg class insists on creating a parser for audio streams, but ffmpeg does not provide one for Vorbis. A decoder is available, which works fine. Nonetheless, AudioDecoderFfmpeg bails out because of the lack of parser.

2. When that hurdle is removed, a synchronisation issue appears; this may be related to the first frame of encoded audio not producing an output, which is only available after the second frame is decoded. I also see a lot of buffer overrun warnings for decoded audio frames.

Bastiaan Jacques <bjacques>
Project Member
Sat 12 Feb 2011 09:27:16 PM UTC, comment #1:

It plays fine with gst.

With ffmpeg, no audio.

10923:1] 22:08:43 ERROR: Could not create Audio decoder: AudioDecoderFfmpeg: could not initialize a parser for ffmpeg codec id 86021

- debian amd64 squeeze

Gabriele Giacone <gg0>
Project Member
Sat 25 Oct 2008 05:00:42 PM UTC, original submission:

easyvideo.swf?url=kiro.ogg

ERROR: MediaParserGst failed to push more data into the demuxer! Seeking back.
ERROR: Error decoding encoded video frame in NetStream input
ERROR: nextVideoFrameTimestamp returned true (0), but decodeNextVideoFrame returned null, I don't think this should ever happen
ERROR: Error decoding encoded video frame in NetStream input
ERROR: nextVideoFrameTimestamp returned true (0), but decodeNextVideoFrame returned null, I don't think this should ever happen

Only a small portion of initial sound can be heared,
no video at all (blank).

Haven't tried ffmpeg actually, so dunno yet if it's only
a MediaParserGst issue...

Sandro Santilli <strk>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by gg0 (Posted a comment)
  • -unavailable- added by bjacques (Updated the item)
  • -unavailable- added by strk (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 9 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 28 Jul 2011 12:52:02 PM UTCstrkAssigned toNone=>sortie
    Sun 20 Feb 2011 02:58:13 AM UTCbjacquesCategoryvideo-gst=>video-ffmpeg
      StatusWorks For Me=>Confirmed
      Assigned tobjacques=>None
      SummaryERROR: MediaParserGst failed to push more data into the demuxer! Seeking back.=>AudioDecoderFfmpeg: could not initialize a parser for ffmpeg codec id 86021
    Sat 12 Feb 2011 09:28:41 PM UTCgg0Open/ClosedClosed=>Open
    Sat 12 Feb 2011 09:27:16 PM UTCgg0Severity5 - Blocker=>3 - Normal
      Open/ClosedOpen=>Closed
    Sat 28 Feb 2009 06:37:46 PM UTCbjacquesStatusNone=>Works For Me

    Back to the top


    Powered by Savane 3.1-cleanup