bugGnash - The GNU Flash player - Bugs: bug #30357, all youtube fail with "An...

 
 

bug #30357: all youtube fail with "An error occurred, please try again later"

Submitted by:  Dongxu Li <butdiene>
Submitted on:  Mon 05 Jul 2010 03:04:59 PM UTC  
 
Category: pluginSeverity: 3 - Normal
Release: trunkStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 23 Aug 2010 02:10:35 PM UTC, comment #12:

NPAPI is the API used in Gecko, which WebKit emulates. This should roughly translate to which version of xulrunner. I also tested this release with Chromium, so it should work fine. If you are having any problems, try blocking the cookies. Basically the YouTube cookie is a redirect to a regional video server, so when cookie handling was broken, it wouldn't handle this correctly.. Blocking the cookies just lets you access the default video server, possibly further away, but it all works fine.

Rob Savoye <rsavoye>
Project Administrator
Mon 23 Aug 2010 02:09:50 PM UTC, comment #11:

P.S: Confirming also for Firefox 3.6.8 / xulrunner 1.9.2.8 after deleting all cookies from youtube.com.

Dennis Schridde <devurandom>
Mon 23 Aug 2010 02:06:09 PM UTC, comment #10:

In reply to comment #9:
Please explain your statement regarding NPAPI. Afaik NPAPI is the the netscape plugin API, which is implemented by the webbrowser.

Which browser versions does it affect? I am using Chromium 6.0.495.0, which is fairly recent.

Hence I do not assume I have to block cookies, do I?

I deleted any existing cookies from youtube.com prior to testing.

Dennis Schridde <devurandom>
Mon 23 Aug 2010 01:47:00 PM UTC, comment #9:

You have to delete all youtube cookies to refresh them. Gnash correctly now handles them if your NPAPI is less than about 2 years old. If it is older, then you have to block the cookies after deleting them.

Rob Savoye <rsavoye>
Project Administrator
Mon 23 Aug 2010 01:42:10 PM UTC, comment #8:

Confirming using 0.8.8 for any video on YouTube.
Maybe it is similar to a problem that also hit MPD: http://musicpd.org/mantis/view.php?id=2954

gnash-dbg.log attached.

# gnash -V
Gnash 0.8.8

Copyright (C) 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of Gnash under the terms of the GNU General
Public License. For more information, see the file named COPYING.

Build options 0.8.8
Renderers: AGG Cairo OpenGL
Hardware Acceleration: VAAPI XVideo
GUI: GTK
Media handlers: ffmpeg
Configured with: --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --docdir=/usr/share/doc/gnash-0.8.8 --disable-dependency-tracking --disable-kparts3 --disable-cygnal --disable-cgibins --disable-docbook --disable-ghelp --enable-kparts4 --disable-lirc --enable-nls --enable-npapi --enable-python --disable-ssh --disable-ssl --disable-testsuite --disable-i810-lod-bias --enable-gui=gtk,kde4,sdl --enable-extensions=mysql,gtk,dbus --enable-renderer=agg,cairo,opengl --enable-hwaccel=xv,vaapi --with-npapi-plugindir=/usr/lib64/gnash/npapi/ --with-plugins-install=system --with-kde4-incl=/usr/include --with-kde4-configdir=/usr/share/config --with-kde4-prefix=/usr --with-kde4-lib=/usr/lib64 --with-kde-appsdatadir=/usr/share/apps/klash --with-kde4-servicesdir=/usr/share/kde4/services --with-kde4-plugindir=/usr/lib64/kde4/plugins --enable-media=ffmpeg
CXXFLAGS: -pipe -O2 -march=athlon64-sse3 -fstack-protector -ftree-vectorize -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type -Wnon-virtual-dtor -Wunused -fvisibility-inlines-hidden
Version: none:20100823

(file #21282)

Dennis Schridde <devurandom>
Fri 13 Aug 2010 11:12:43 AM UTC, comment #7:

threads support for the libcurl breaks

CurlSession::importCookies()

disabling threads support from libcurl fixes this problem. It's also possible to add threads support from gnash side in CurlSession::importCookies()

Dongxu Li <butdiene>
Mon 19 Jul 2010 02:15:00 PM UTC, comment #6:

I have removed and reinstalled the plugin many times, so it's not not an old leftover for sure.

a fresh seamonkey-2.0.5 installation gets the same error, even if cookies are blocked globally in seamonkey. Blocking cookies in firefox doesn't help either.

Dongxu Li <butdiene>
Mon 19 Jul 2010 06:14:36 AM UTC, comment #5:

Did you 'make install-plugin' ?
Did you clear your youtube.com cookies once after upgrade ?

Sandro Santilli <strk>
Project Member
Sun 18 Jul 2010 05:46:35 PM UTC, comment #4:

it still happens with trunk revision: 12309
on firefox 3.6.6

Dongxu Li <butdiene>
Thu 15 Jul 2010 12:35:34 PM UTC, comment #3:

Gnash from trunk, coupled with a new enough Firefox version (3.6.5 known to work), should work w/out hacks.

This is probably a duplicate bug, ntw.

Sandro Santilli <strk>
Project Member
Thu 15 Jul 2010 12:18:59 PM UTC, comment #2:

I just followed these instructions:
http://turanct.wordpress.com/2010/02/25/gnash-youtube/

http://guide.debianizzati.org/index.php/Visualizzare_filmati_YouTube_con_Gnash_e_GreaseMonkey#Preparare_lo_script_che_cambier.C3.A0_il_player_di_default_di_YouTube_da_flash_a_gnash

And after that gnash worked nicely. Anyway I would much prefer not to need such hacks.

Anonymous
Tue 06 Jul 2010 03:47:08 PM UTC, comment #1:

the same error happens for gnash-0.8.7 as well.

gnash -V
Gnash 0.8.7

Copyright (C) 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of Gnash under the terms of the GNU General
Public License. For more information, see the file named COPYING.

Build options 0.8.7
Target:
Renderer: agg - GUI: GTK - Media handler: ffmpeg
Configured with: --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --docdir=/usr/share/doc/gnash-0.8.7 --disable-dependency-tracking --disable-kparts3 --enable-avm2 --disable-cygnal --disable-cgibins --disable-docbook --enable-ghelp --enable-npapi --disable-kparts4 --disable-lirc --enable-nls --enable-npapi --enable-python --enable-ssh --enable-ssl --disable-testsuite --enable-i810-lod-bias --enable-gui=gtk --enable-extensions=mysql,gtk,dbus --with-npapi-plugindir=/opt/netscape/plugins --enable-renderer=agg --enable-media=ffmpeg
CXXFLAGS: -O2 -march=native -fomit-frame-pointer -fexpensive-optimizations -pipe -D__STDC_CONSTANT_MACROS -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type -Wnon-virtual-dtor -Wunused -fvisibility-inlines-hidden
Version: .:
Built against ffmpeg version: Lavc52.72.2

Dongxu Li <butdiene>
Mon 05 Jul 2010 03:04:59 PM UTC, original submission:

all youtube videos fail wtih ""An error occurred, please try again later". I was told that disabling/deleting cookies might help, but I still couldn't play any youtube yet.

gnash trunk: revision 12280

$ gnash -V
Gnash trunk

Copyright (C) 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of Gnash under the terms of the GNU General
Public License. For more information, see the file named COPYING.

Build options trunk
Renderers: AGG
Hardware Acceleration: XVideo
GUI: GTK - Media handler: ffmpeg
Configured with: --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tracking --enable-avm2 --disable-cygnal --disable-cgibins --disable-docbook --enable-ghelp --enable-npapi --disable-kparts4 --disable-lirc --enable-nls --enable-npapi --enable-python --enable-ssh --enable-ssl --disable-testsuite --disable-i810-lod-bias --enable-gui=gtk --enable-extensions=mysql,gtk,dbus --with-npapi-plugindir=/opt/netscape/plugins --enable-renderer=agg --enable-media=ffmpeg --enable-hwaccel=XVideo,omap
CXXFLAGS: -O2 -march=native -fomit-frame-pointer -fexpensive-optimizations -pipe -D__STDC_CONSTANT_MACROS -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type -Wnon-virtual-dtor -Wunused -fvisibility-inlines-hidden
Version: .:
Built against ffmpeg version: Lavc52.72.2

Dongxu Li <butdiene>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #21282:  gnash-dbg.log.xz added by devurandom (27kB - application/x-xz)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rsavoye (Posted a comment)
  • -unavailable- added by devurandom (Updated the item)
  • -unavailable- added by strk (Posted a comment)
  • -unavailable- added by butdiene (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 23 Aug 2010 01:47:00 PM UTCrsavoyeOpen/ClosedOpen=>Closed
    Mon 23 Aug 2010 01:42:10 PM UTCdevurandomAttached File-=>Added gnash-dbg.log.xz, #21282

    Back to the top


    Powered by Savane 3.1-cleanup