bugGNU Octave - Bugs: bug #56477, [octave forge] (parallel)...

 
 

bug #56477: [octave forge] (parallel) installation error 'command_editor', 'octave_env' has not been declared

Submitted by:  Aditya Ardiya <ardiya>
Submitted on:  Wed 12 Jun 2019 07:28:55 AM UTC  
 
Category:  Octave Forge Package Severity:  2 - Minor
Priority:  5 - Normal Item Group:  Installation Failure
Status:  Patch Submitted Assigned to:  Olaf Till <i7tiol>
Originator Name:  Aditya Ardiya Open/Closed:  Open
Release:  5.1.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sat 06 Jul 2019 07:05:45 AM UTC, comment #6: 

Please do not make such verbose use of the "Quote" feature.  It makes this discussion more difficult to follow, if you read large posts doubled.  Please quote whole posts by just giving a reference "comment #X" to it, like I do in the following.

I understand, that your problem is solved by comment #3 for all openSUSE 15.1 users.  A limited set of users.  The original author Aditya Ardiya might not use this distribution and wants a convenient solution as well.

The reason for comment #4 is a solution inspired by openSUSE for all Linux distributions.

Kai Torben Ohlhus <siko1056>
Project Member
Sat 06 Jul 2019 06:38:41 AM UTC, comment #5: 

Thanks. Installing the latest package release (3.1.3) from octave forge did not work, and while I was able to compile Olaf's patch from 5/4/2019 (https://sourceforge.net/p/octave/parallel/ci/8a9ddd2b2da329b87a59c50ffd1d17096a860597/log/?path= ), I was still not able to get parcellfun to work.

As I wrote in my comment #3 below, however, I did manage to get things to work using the packages octave-forge-parallel (and  octave-forge-struct) for OpenSUSE Leap 15.1. Things are working fine now. Thanks!

comment #4:

> The openSUSE maintainers extracted a patch from the upstream commits by Olaf.
>
> See
> https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel-build-with-octave5.patch?expand=1
> and
> https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel.changes?expand=1
>
> If you need this package to work (without guarantees by the Maintainer Olaf) you can try to install the attached patched version independent of the used Linux distribution from the Octave command prompt:
>

> urlwrite ("https://savannah.gnu.org/bugs/download.php?file_id=47160", "parallel-3.1.3-Octave-5.1.0-patch.tar.gz")
> pkg install parallel-3.1.3-Octave-5.1.0-patch.tar.gz

>
> And finally I can verify that things seem to work:
>

> pkg load parallel
> A = rand(10000);
> A = {A, A, A, A, A; A, A, A, A, A};
> B = parcellfun (4, @sin, A, "UniformOutput", false);
>
> parcellfun: 10/10 jobs done

>


comment #4:

> The openSUSE maintainers extracted a patch from the upstream commits by Olaf.
>
> See
> https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel-build-with-octave5.patch?expand=1
> and
> https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel.changes?expand=1
>
> If you need this package to work (without guarantees by the Maintainer Olaf) you can try to install the attached patched version independent of the used Linux distribution from the Octave command prompt:
>

> urlwrite ("https://savannah.gnu.org/bugs/download.php?file_id=47160", "parallel-3.1.3-Octave-5.1.0-patch.tar.gz")
> pkg install parallel-3.1.3-Octave-5.1.0-patch.tar.gz

>
> And finally I can verify that things seem to work:
>

> pkg load parallel
> A = rand(10000);
> A = {A, A, A, A, A; A, A, A, A, A};
> B = parcellfun (4, @sin, A, "UniformOutput", false);
>
> parcellfun: 10/10 jobs done

>

William Krivan <krivanw>
Sat 06 Jul 2019 06:21:29 AM UTC, comment #4: 

The openSUSE maintainers extracted a patch from the upstream commits by Olaf.

See
https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel-build-with-octave5.patch?expand=1
and
https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1/octave-forge-parallel/octave-forge-parallel.changes?expand=1

If you need this package to work (without guarantees by the Maintainer Olaf) you can try to install the attached patched version independent of the used Linux distribution from the Octave command prompt:

urlwrite ("https://savannah.gnu.org/bugs/download.php?file_id=47160", "parallel-3.1.3-Octave-5.1.0-patch.tar.gz")
pkg install parallel-3.1.3-Octave-5.1.0-patch.tar.gz

And finally I can verify that things seem to work:

pkg load parallel
A = rand(10000);
A = {A, A, A, A, A; A, A, A, A, A};
B = parcellfun (4, @sin, A, "UniformOutput", false);

parcellfun: 10/10 jobs done

Kai Torben Ohlhus <siko1056>
Project Member
Sat 06 Jul 2019 01:46:24 AM UTC, comment #3: 

Update:

On OpenSUSE 15.1, I uninstalled the struct package (which I had installed previously) from octave (using the usual "pkg uninstall struct"). Then I installed the octave-forge-parallel package (version 3.1.3-lp151.2.2) with YaST2, where the octave-forge-struct package (version 1.0.15-lp151.2.1) was automatically installed as well. All is working fine now.

comment #2:

> Hi,
>
> I ran into errors when I was trying to install the octave parallel package after an OS upgrade from Opensuse 15.0 to 15.1 (the latter uses octave 5.1.0). I see the problems I am encountering have been reported here.
>
> Do you by any chance have an update?
>
> Thanks so much,
>
> WK
>

William Krivan <krivanw>
Sat 29 Jun 2019 07:17:24 PM UTC, comment #2: 

Hi,

I ran into errors when I was trying to install the octave parallel package after an OS upgrade from Opensuse 15.0 to 15.1 (the latter uses octave 5.1.0). I see the problems I am encountering have been reported here.

Do you by any chance have an update?

Thanks so much,

WK

William Krivan <krivanw>
Wed 12 Jun 2019 02:45:10 PM UTC, comment #1: 

I do face those very same errors.  The package maintainer Olaf mentioned about one month ago [1], that the parallel package "needs a general overhaul" to work with Octave 5.1.0.  Maybe you can follow Olafs work in the development repository [2].

[1] https://lists.gnu.org/archive/html/help-octave/2019-04/msg00136.html
[2] https://sourceforge.net/p/octave/parallel/ci/default/tree/

Kai Torben Ohlhus <siko1056>
Project Member
Wed 12 Jun 2019 07:28:55 AM UTC, original submission:  

I am using Octave 5.1.0 and I receive the error below when running pkg install -forge parallel

octave:1> pkg install -forge  struct
For information about changes from previous versions of the struct package, run 'news struct'.
octave:2> pkg install -forge parallel
configure: WARNING: TLS disabled since gnutls/gnutls.h not found or not compilable
pconnect.cc: In function ‘octave_value_list Fpconnect(const octave_value_list&, int)’:
pconnect.cc:536:35: error: ‘octave_env’ has not been declared
           std::string directory = octave_env::get_current_directory ();
                                   ^~~~~~~~~~
In file included from parallel-gnutls.h:135:0,
                 from pserver.cc:49:
pserver.cc: In function ‘void reval_loop(octave_parallel_stream&)’:
pserver.cc:142:55: warning: ‘octave_value_list octave::eval_string(const string&, bool, int&, int)’ is deprecated: [5]: use 'octave::interpreter::eval_string' instead [-Wdeprecated-declarations]
       SET_ERR (OCTAVE__EVAL_STRING (s, false, p_err, 0), err);
                                                       ^
error-helpers.h:116:9: note: in definition of macro ‘SET_ERR’
         code ; \
         ^~~~
In file included from oct-alt-includes.h:33:0,
                 from config.h:258,
                 from pserver.cc:26:
/usr/local/include/octave-5.1.0/octave/../octave/parse.h:589:3: note: declared here
   eval_string (const std::string&, bool silent, int& parse_status, int nargout);
   ^~~~~~~~~~~
pserver.cc:172:13: error: ‘command_editor’ has not been declared
             command_editor::increment_current_command_number ();
             ^~~~~~~~~~~~~~
pserver.cc: In function ‘octave_value_list Fpserver(const octave_value_list&, int)’:
pserver.cc:1119:23: error: ‘octave_env’ has not been declared
           int cd_ok = octave_env::chdir (directory.c_str ());
                       ^~~~~~~~~~
pserver.cc:1122:13: error: ‘octave_env’ has not been declared
             octave_env::chdir ("/tmp");
             ^~~~~~~~~~
make: *** [pconnect.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [pserver.o] Error 1
make: Entering directory '/tmp/oct-MYzJWb/parallel-3.1.3/src'
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c pconnect.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c pserver.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c sclose.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c reval.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c precv.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c psend.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c select_sockets.cc
CXX="g++" CXXFLAGS="-g -O2  " /usr/local/bin/mkoctfile-5.1.0 -c network_get_info.cc
Makefile:150: recipe for target 'pconnect.o' failed
Makefile:150: recipe for target 'pserver.o' failed
make: Leaving directory '/tmp/oct-MYzJWb/parallel-3.1.3/src'

pkg: error running `make' for the parallel package.
error: called from
    configure_make at line 99 column 9
    install at line 184 column 7
    pkg at line 441 column 9

Aditya Ardiya <ardiya>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by krivanw (Posted a comment)
  • -email is unavailable- added by siko1056 (Package maintainer.)
  • -email is unavailable- added by siko1056 (Updated the item)
  • -email is unavailable- added by ardiya (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-07-06 siko1056 Attached File- => Added octave-forge-parallel-build-with-octave5.patch, #47159
        Attached File- => Added parallel-3.1.3-Octave-5.1.0-patch.tar.gz, #47160
        StatusConfirmed => Patch Submitted
    2019-06-12 siko1056 Carbon-Copy- => Added i7tiol
    2019-06-12 siko1056 Severity3 - Normal => 2 - Minor
        StatusNone => Confirmed
        Assigned toNone => i7tiol
    2019-06-12 siko1056 SummaryError when installing parallel from forge: 'command_editor', 'octave_env' has not been declared => [octave forge] (parallel) installation error 'command_editor', 'octave_env' has not been declared

    Back to the top


    Powered by Savane 3.5