bugGNU Octave - Bugs: bug #54708, Segfault closing plot fig on...

 
 

bug #54708: Segfault closing plot fig on precompiled octave on Mojave

Submitted by:  Marco Parvis <marco_parvis>
Submitted on:  Sat 22 Sep 2018 01:13:04 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  None Assigned to:  None
Originator Name:  Marco Parvis Open/Closed:  Open
Release:  4.4.1 Operating System:  Mac OS

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 22 Sep 2018 01:13:04 PM UTC, original submission:

Installed octave via home-brew on osx mojave beta in a virtual machine and run the attached script
Everything is OK, but when closing the picture a segfault is got and octave crashes

Installing octave with --with-qt (and a compilation) works in command line mode perfectly. (PS: the guy mode has still problems, but this is not the described issue)

Suspect octave needs only to be recompiled in home-brew to remove the problem

Marco Parvis <marco_parvis>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #45074:  octrev.m added by marco_parvis (3KiB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by marco_parvis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-09-22 marco_parvis Attached File- => Added octrev.m, #45074

    Back to the top


    Powered by Savane 3.3