bugGNU Octave - Bugs: bug #54658, Private directory in +package

 
 

bug #54658: Private directory in +package

Submitted by:  Guillaume <gyom>
Submitted on:  Thu 13 Sep 2018 04:19:41 PM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Matlab Compatibility
Status:  Duplicate Assigned to:  None
Originator Name:  Guillaume Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 14 Sep 2018 09:23:11 AM UTC, comment #3:

Thanks Mike; it's the second time you point bug #45444 to me, I didn't find it as I made a search with the 'package' keyword instead of 'namespace'...
So, yes, same concern than in bug #45444; this other bug report also describe similar issues with classdef. I would guess they require independent fixes though.

Guillaume <gyom>
Thu 13 Sep 2018 07:01:29 PM UTC, comment #2:

I'm pretty sure this is a duplicate of open bug #45444, can you take a look at the discussion and examples there and confirm that this is about the same issue?

Mike Miller <mtmiller>
Project Administrator
Thu 13 Sep 2018 06:46:34 PM UTC, comment #1:

I thought that maybe this had to do with the need to use mypkg before the function name, such as in calling mypkg.myfcn2 below. However mypkg.myprivatefcn doesn't work either. However the following runs successfully in matlab if and only if mypkg is not before the private function call.

Marshall <marsian>
Thu 13 Sep 2018 04:19:41 PM UTC, original submission:

Functions in a private directory of a +package cannot be called:

Guillaume <gyom>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by marsian (Posted a comment)
  • -email is unavailable- added by gyom (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-09-19 mtmiller Carbon-CopyRemoved 80942 => -
    2018-09-14 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #45444

    Back to the top


    Powered by Savane 3.3