bugGNU Octave - Bugs: bug #53889, dev fails to compile with Qt 4.6.2

 
 

bug #53889: dev fails to compile with Qt 4.6.2

Submitted by:  A.R. Burgers <arb>
Submitted on:  Sun 13 May 2018 10:52:43 AM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  3 - Low Item Group:  Build Failure
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 30 Dec 2018 09:19:32 PM UTC, comment #8:

I added an announcement to the NEWS file that the minimum supported Qt version is 4.8, while Qt5 is preferred. See https://hg.savannah.gnu.org/hgweb/octave/rev/c5a909b164de.

Closing report.

Rik <rik5>
Project Administrator
Sun 30 Dec 2018 07:04:16 PM UTC, comment #7:

That was confusing, I'll try again. Octave (stable and default) currently fails with Qt 4.6. It currently builds completely with Qt 4.8. I am happy with the current state of affairs and would be disappointed if we decided to make a change to intentionally drop Qt 4.8 support for Octave 5 for some reason. I am ok with closing this as won't fix and saying we officially don't support Qt 4.6.

Mike Miller <mtmiller>
Project Administrator
Sun 30 Dec 2018 06:44:06 PM UTC, comment #6:

Octave continues to build with Qt 4.8, I have my own daily build on Qt 4.8 that is still working today. I have no problem with limiting our support for Qt 4.8 for this release. On the version 6 branch we could look at supporting only a modern version of Qt 5.

Mike Miller <mtmiller>
Project Administrator
Sun 30 Dec 2018 12:59:20 PM UTC, comment #5:

@Mike: Do we want to maintain support for Qt4 for the 5.0 release? If so a configuration test and #ifdef need to be added as suggested in comment #3. Otherwise, we can close this report.

Rik <rik5>
Project Administrator
Sat 19 May 2018 01:53:25 PM UTC, comment #4:

In the mean time I did an upgrade to Qt 5.4 on RHEL, using the installer from the Qt website, which proved to be much easier than I had anticipated, and move on from 4.6.2.

A.R. Burgers <arb>
Thu 17 May 2018 09:35:00 PM UTC, comment #3:

Marking as confirmed, but lowering the priority as most distributions will have Qt 4.8 or better. It would be relatively simple to add a configuration test in m4/acinclude.m4 and then use #if defined in file-editor-tab.cc to choose between two different code options. As an example of how to code such a test, see

I don't have time to work on this myself.

Rik <rik5>
Project Administrator
Thu 17 May 2018 07:37:16 PM UTC, comment #2:

I think we might want to continue to support Qt 4.8 if it's not too much trouble, since that is the last release of Qt 4 and still widely available. But yes, dropping Qt 4 completely is an option.

Most of the Qt feature tests are commented with the corresponding minimum Qt version.

The only mainstream distros that have Qt 4.6 and not Qt 4.8 are Red Hat Enterprise and CentOS (both 6 and 7).

Mike Miller <mtmiller>
Project Administrator
Thu 17 May 2018 07:00:16 PM UTC, comment #1:

Maybe we should just drop al Qt4 support at the next release (4.6.0).

Rik <rik5>
Project Administrator
Sun 13 May 2018 10:52:43 AM UTC, original submission:

compilation fails with this error:

QDateTime::currentDateTimeUtc() was introduced in Qt 4.7 according to http://doc.qt.io/archives/qt-4.8/qdatetime.html#currentDateTimeUtc

A.R. Burgers <arb>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by arb (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-01-02 rik5 Open/ClosedOpen => Closed
    2018-12-30 rik5 StatusConfirmed => Wont Fix
    2018-05-17 rik5 Priority5 - Normal => 3 - Low
        StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.4