bugGNU Octave - Bugs: bug #53631, gnuplot fails to run in MXE Octave...

 
 

bug #53631: gnuplot fails to run in MXE Octave built for win32

Submitted by:  Rik <rik5>
Submitted on:  Fri 13 Apr 2018 02:24:22 AM UTC  
 
Category: Configuration and Build SystemSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Regression
Status: Wont FixAssigned to: None
Originator Name: Open/Closed: Closed
Release: 4.3.90Operating System: Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 16 Apr 2018 03:43:10 PM UTC, comment #3:

I found this thread about compiling gnuplot and d2d1 (https://sourceforge.net/p/gnuplot/support-requests/227/). Apparently, in gnuplot 5.2 they introduced a Direct2D API (with corresponding system code in d2d1.dll). Windows XP does not have this DLL so it is really just about an unsupported old OS. Closing report.

Rik <rik5>
Project Administrator
Sat 14 Apr 2018 11:05:49 AM UTC, comment #2:

Thats correct name for it since we use mingw-w64 for the runtime/compiler libs.

i686-w64-mingw32 = 32bit
x86_64-w64-mingw32 = 64 bit

John Donoghue <lostbard>
Project Member
Fri 13 Apr 2018 02:27:37 AM UTC, comment #1:

One thing that I noticed was that when starting Octave it says:

Should the second item be -w32-?

Rik <rik5>
Project Administrator
Fri 13 Apr 2018 02:24:22 AM UTC, original submission:

I built my own copy of Octave for Windows using MXE and the additional option --disable-windows-64 since this is for a 32-bit Windows XP VM.

A valid installer file was created and Octave installs and seems to run just fine. However, gnuplot does not work. It is listed as an available_graphics_toolkit. But when I try to switch to it, Octave complains that the version is too old.

If I go into the directory C:\Octave\Octave-4.3.90\bin and run gnuplot.exe directly then the OS complains that the dll d2d1.dll was not found.

Rik <rik5>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by lostbard (Posted a comment)
  • -unavailable- added by rik5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 16 Apr 2018 03:43:10 PM UTCrik5StatusNone=>Wont Fix
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup1