bugGNU Octave - Bugs: bug #53336, axis equal clears plot when called...

 
 

bug #53336: axis equal clears plot when called after xlim/ylim

Submitted by:  None
Submitted on:  Tue 13 Mar 2018 03:11:21 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  None Assigned to:  None
Originator Name:  Wilfrid Ingignoli Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  4.2.1
Operating System:  Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 13 Mar 2018 03:11:21 PM UTC, original submission:

The following script

x = -1:0.01:1;
y = x;
figure(1);
plot(x, y);
xlim([-0.2, 0.2]);
ylim([-0.5, 0.5]);
axis('equal');

causes the figure to clear after the "axis equal" command is invoked.

Closed bug https://savannah.gnu.org/bugs/?49755 corrected the issue "axis equal clears plot". But, if we invoke the "xlim/ylim" command before invoking the "axis equal" command, the "axis equal" command still causes the figure to clear.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can add your encouragement to it.
This task has 0 encouragements so far.

Only project members can vote.

 

 

 

No changes have been made to this item

Back to the top


Powered by Savane 3.3