bugmake - Bugs: bug #51267, Improve error handling after a...

 
 

bug #51267: Improve error handling after a special command

Submitted by:  Markus Elfring <elfring>
Submitted on:  Mon 19 Jun 2017 04:08:34 PM UTC  
 
Severity:  3 - Normal Item Group:  Documentation
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  4.2.1 Operating System:  Any
Fixed Release:  None Triage Status:  None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 15 Sep 2018 08:17:58 PM UTC, comment #1:

The very first line in the recipe command in that example is:

This means that any command that fails in the recipe command immediately exits that command with an error. There is no need to check every command individually for errors.

Paul D. Smith <psmith>
Project Administrator
Mon 19 Jun 2017 04:08:34 PM UTC, original submission:

I have noticed the following code fragment in a recipe which is mentioned in the section “Generating prerequisites automatically” of the documentation.
https://www.gnu.org/software/make/manual/html_node/Automatic-Prerequisites.html#index-make-depend


$(CC) -M $(CPPFLAGS) $< > $@.$$$$; \

The semicolon indicates at the end that the return value is ignored there. I imagine that further data processing should usually only be performed if this command succeeded.
Would you like to improve the exception handling for such a situation?

Markus Elfring <elfring>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Updated the item)
  • -email is unavailable- added by elfring (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-09-15 psmith StatusNone => Not A Bug
        Open/ClosedOpen => Closed
    2017-07-02 psmith Item GroupBug => Documentation

    Back to the top


    Powered by Savane 3.3