bugGNU gettext - Bugs: bug #49497, gettext needs automake 1.13

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #49497: gettext needs automake 1.13

Submitted by:  Karl-P. Richter <krichter>
Submitted on:  Mon 31 Oct 2016 11:58:15 PM UTC  
 
Category: BuildSeverity: 3 - Normal
Item Group: NoneStatus: Fixed
Privacy: PublicAssigned to: Daiki Ueno <ueno>
Open/Closed: Closed

Tue 02 Jan 2018 07:34:09 PM UTC, comment #3:

Daiki fixed the information in the HACKING file.

I think that's all that needs to be done.

> It'd be nice if `autogen.sh` would fail with a verbose error message and give a hint that automake 1.13 needs to be installed rather than just complain about the missing macro.


This would be overkill. We do add all kinds of checks into 'configure', because the person who runs 'configure' is not meant to have special knowledge about the package or particular debugging skills. But the person who reconfigures the package can be assumed to have looked in the HACKING file and to have debugging skills.

Bruno Haible <haible>
Project Administrator
Wed 02 Nov 2016 04:33:13 AM UTC, comment #2:

> It'd be nice if `autogen.sh` would fail with a verbose error message and give a hint that automake 1.13 needs to be installed rather than just complain about the missing macro.


I thought it would be achieved by the AM_INIT_AUTOMAKE invocation in configure.ac:
AM_INIT_AUTOMAKE([1.13 silent-rules parallel-tests dist-xz dist-lzip])

Perhaps it might not work with older automake?

> IMO these comments should be moved to HACKING. And, if necessary, add the required version numbers there.


Good idea, done:
http://git.savannah.gnu.org/cgit/gettext.git/commit/?id=f837369264c119d0e96c9ba6e5960deba59eee73

Daiki Ueno <ueno>
Project AdministratorIn charge of this item.
Tue 01 Nov 2016 06:36:54 AM UTC, comment #1:

Daiki,

The autogen.sh file lists some dependencies:
# This script requires:
# - Autoconf
# - Automake
# - Wget
# - Git
# - XZ Utils

IMO these comments should be moved to HACKING. And, if necessary, add the required version numbers there.

Bruno Haible <haible>
Project Administrator
Mon 31 Oct 2016 11:58:15 PM UTC, original submission:

`autogen.sh` needs macro `AM_EXTRA_RECURSIVE_TARGETS` which is provided by automake 1.13 (see https://travis-ci.org/krichter722/gettext/builds/172155647 for details). It'd be nice if `autogen.sh` would fail with a verbose error message and give a hint that automake 1.13 needs to be installed rather than just complain about the missing macro.

experience with v0.19.8.1-14-gd2a29c9

Karl-P. Richter <krichter>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by ueno (Posted a comment)
  • -unavailable- added by haible (Posted a comment)
  • -unavailable- added by krichter (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 02 Jan 2018 07:34:09 PM UTChaibleStatusNone=>Fixed
      Assigned toNone=>ueno
      Open/ClosedOpen=>Closed
    Sun 27 Nov 2016 12:18:45 PM UTChaibleCategoryNone=>Build

    Back to the top


    Powered by Savane 3.1-cleanup1