bugGNU Octave - Bugs: bug #49457, Octave does not respond on...

 
 

bug #49457: Octave does not respond on plot-commands

Submitted by:  None
Submitted on:  Thu 27 Oct 2016 02:43:54 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Ingo Seifert Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.0.3
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 01 Nov 2016 07:34:07 AM UTC, comment #4:

Closing as duplicate of #45458

Andreas Weber <andy1978>
Project Member
Tue 01 Nov 2016 07:05:46 AM UTC, comment #3:

Thanks a lot Andreas and Dan! I followed your advice and waited for about 3 minutes and it worked!

Anonymous
Sun 30 Oct 2016 09:38:04 AM UTC, comment #2:

@Ingo: Can you please try a simple

plot (1:10)

and then wait at least 3min?

Background: When plotting for the first time with the GUI the fontconfig cache is built and this can take some minutes dependent on your CPU and how many fonts are installed.

And try Dan's code to see if all graphics_toolkit doesn't work. Be sure to call "close all" before switching to another toolkit

Andreas Weber <andy1978>
Project Member
Fri 28 Oct 2016 04:06:08 PM UTC, comment #1:

Which plotting toolkit?  Just one?  All of them.  Experiment with

graphics_toolkit("qt");
for i=1:10
  X=[1 2 3 4 5 6];
  plot(X);
endfor

graphics_toolkit("fltk");
for i=1:10
  X=[1 2 3 4 5 6];
  plot(X);
endfor

graphics_toolkit("gnuplot");
for i=1:10
  X=[1 2 3 4 5 6];
  plot(X);
endfor

On my linux system I've had a problem similar to what you describe for "qt" only.  The other two work fine without the window freezing.

Dan Sebald <sebald>
Thu 27 Oct 2016 02:43:54 PM UTC, original submission:

Hello,

if I type easy plot-commands in Octave the programme does not work. Sometimes the plot-specific window opens but with white background and now picture. Even if I type
X=[1 2 3 4 5 6]
and
plot(X)
the problem occurs.
Maybe it's because I'm using Windows 10. Or may not installing Java be the reason? Could you fix this, please?

Best regards
Ingo

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-01 andy1978 StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #45458

    Back to the top


    Powered by Savane 3.4