bugGNU GRUB - Bugs: bug #48619, have_exec should be y for cygwin

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #48619: have_exec should be y for cygwin

Submitted by:  Xuan Guo <nbdd0121>
Submitted on:  Sun 24 Jul 2016 10:15:00 PM UTC  
 
Category:  Configuration Severity:  Major
Priority:  5 - Normal Item Group:  Hardware-specific
Status:  None Privacy:  Public
Assigned to:  None Originator Name: 
Open/Closed:  Open Release: 
Release:  Git master Reproducibility:  Every Time
Planned Release:  None

Mon 25 Jul 2016 06:15:58 PM UTC, comment #1:

The only place where this condition is used is grub-mkrescue. Which other programs do you mean?

Andrei Borzenkov <arvidjaar>
Project Member
Sun 24 Jul 2016 10:15:00 PM UTC, original submission:

For Cygwin, have_exec should be y instead of n. As a consequence of being n, grub-mkrescue and some other programs are not compiled. A simple patch is attached. After patching grub-mkrescue compiles and runs without problem.

Xuan Guo <nbdd0121>

 

Attached Files
file #38012:  patch added by nbdd0121 (340B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by arvidjaar (Posted a comment)
  • -email is unavailable- added by nbdd0121 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-07-24 nbdd0121 Attached File- => Added patch, #38012

    Back to the top


    Powered by Savane 3.3