bugGNU Wget - Bugs: bug #45776, ClamAV integration?

 
 

bug #45776: ClamAV integration?

Submitted by:  Noël Köthe <nok>
Submitted on:  Mon 17 Aug 2015 08:28:07 AM UTC  
 
Category:  Feature Request Severity:  3 - Normal
Priority:  5 - Normal Status:  Wont Fix
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  None Operating System:  None
Reproducibility:  None Fixed Release:  None
Planned Release:  None Regression:  None
Work Required:  None Patch Included:  No

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 18 Aug 2015 11:51:56 PM UTC, comment #2: 

I agree a clamav specific feature isn't appropiate, but a feature that notifies (execs) a script of file completion would be, and such feature would solve the request IMHO
(use as command: clam[d]scan --remove)

Ángel <angel_>
Tue 18 Aug 2015 02:39:22 PM UTC, comment #1: 

I partially agree with what Micah had to say. A specific option to pass files through ClamAV is not too general.

And as Micah points out, storing this entire file in memory is a problem in itself. I don't see the point of supporting any similar styled options. One may however ask Wget to pass the downloaded file via a pipe to another process that can handle such a requirement.

I'm closing this for now. If someone has an interesting approach which makes sense in a general way, please come forward, and we can re-open this ticket.

Darshit Shah <darnir>
Project Administrator
Mon 17 Aug 2015 08:28:07 AM UTC, original submission:  

Hello,

this is an older feature request with a comment from a former maintainer which might result in wonfix, but maybe I'm wrong:

--8<--
From: Micah Cowan <micah@...>
...
Nigel Horne wrote:

> Please add an option to pass the file through ClamAV. If the file is infected it isn't saved.


That's not very general, and isn't a particularly useful feature anyway, since one can very easily run the files through ClamAV after they've been saved. Scanning-and-then-saving implies it would have to be saved to a temporary file anyway, or else handled entirely in memory (which is generally unreasonable).

Wget upstream development is planning to eventually support more generic process-filtered/plugin mechanisms for handling such things as link-parsing, content-filtering, and probably filestore management (such as saving to a tarball or multipart/related archive). That last feature would make a suitable general hook for plugging in a ClamAV scanner, perhaps, which could simply decline to save the files it doesn't like. Still have the same problem, though, of needing to save to a temporary file or else hold it in memory.
--8<--
https://bugs.debian.org/496583

thx for your feedback.

Noël Köthe <nok>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by angel_ (Posted a comment)
  • -email is unavailable- added by darnir (Posted a comment)
  • -email is unavailable- added by nok (Submitted the item)
  • -email is unavailable- added by nok
  •  

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-08-18 darnir StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2015-08-17 nok Carbon-Copy- => Added 496583@bugs.debian.org

    Back to the top


    Powered by Savane 3.5