bugGNUstep - Bugs: bug #44825, Apps can't read special chars...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #44825: Apps can't read special chars after unfocus

Submitted by:  Gustav <gustavfn>
Submitted on:  Mon 13 Apr 2015 11:51:07 AM UTC  
 
Category:  Gui/AppKit Severity:  3 - Normal
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Declined

( Jump to the original submission)

Tue 05 May 2015 09:04:02 PM UTC, comment #10:

What kind of workarounds?
If it is not a GS bug, this should be closed.

Riccardo Mottola <rmottola>
Project Member
Mon 27 Apr 2015 07:24:39 PM UTC, comment #9:

No but everyone has a work-around. I found some on a google.

Gustav <gustavfn>
Mon 27 Apr 2015 07:20:58 PM UTC, comment #8:

Good to know. So this is not a bug on GNUstep.

Germán Arias <espectador>
Sun 26 Apr 2015 09:36:22 AM UTC, comment #7:

Starting terminal with >>$ XMODIFIERS="" Terminal<< will make everything work as expected.

Gustav <gustavfn>
Sun 26 Apr 2015 06:15:52 AM UTC, comment #6:

I think the problem could be in -preocess_key_event in XGServerEvent.m in back.

Germán Arias <espectador>
Sun 26 Apr 2015 05:18:27 AM UTC, comment #5:

See method -handleKeyboardEvents:client: in NSInputManager. I added:

NSLog([theEvent description]);

inside the while loop. Wiht this, the first time I press AltGr + ` and the space I get only one NSEvent object:

Gemas[5100:5100] NSEvent: eventType = keyDown, point = { 1.000000, 504.000000 }, modifiers = 0, time = 0.000000, window = 17, dpsContext = 0x26ad940, repeat = NO, keys = `, ukeys = (null), keyCode = 0x0

and of course this works. But then, after unfocus, I get two events, one to AltGr + ` :

Gemas[5100:5100] NSEvent: eventType = keyDown, point = { 212.000000, 396.000000 }, modifiers = 524288, time = 1946.818000, window = 17, dpsContext = 0x26ad940, repeat = NO, keys = (null), ukeys = }, keyCode = 0x33

and other for the space:

Gemas[5100:5100] NSEvent: eventType = keyDown, point = { 212.000000, 396.000000 }, modifiers = 0, time = 1971.700000, window = 17, dpsContext = 0x26ad940, repeat = NO, keys = , ukeys = , keyCode = 0x41

Germán Arias <espectador>
Fri 24 Apr 2015 05:41:41 PM UTC, comment #4:

I've been trying to navigate the sources to find the location of this problem. I can't find where key input is handled, though. Any ideas?

Gustav <gustavfn>
Fri 24 Apr 2015 05:38:22 PM UTC, comment #3:

I can reproduce this on my laptop where I need press AltGr + `. This happen with all apps (Ink, Gemas and Terminal). I will look into this at weekend.

Germán Arias <espectador>
Thu 23 Apr 2015 02:13:08 PM UTC, comment #2:

Shift+` first and then, space.
I think it's called "dead keys" in X11.

Gustav <gustavfn>
Thu 23 Apr 2015 05:01:17 AM UTC, comment #1:

This works for me with Spanish keyboard. Need you press some modifier key to get the ` character? Work this in a non gnustep terminal? What character set are you using in Terminal.app?

Germán Arias <espectador>
Mon 13 Apr 2015 11:51:07 AM UTC, original submission:

How to reproduce:
1) Start Terminal.app.
2) On a Swedish keyboard, hit ` and space. You should now see the character in the buffer.
3) Focus some other window, such as your webbrowser.
4) Now go back and redo step 2. This will now only produce a space and no ` character.

Thanks.

Gustav <gustavfn>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rmottola (Posted a comment)
  • -email is unavailable- added by espectador (Posted a comment)
  • -email is unavailable- added by gustavfn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-07-26 rmottola StatusNone => Invalid
        Open/ClosedOpen => Declined

    Back to the top


    Powered by Savane 3.4