bugfindutils - Bugs: bug #44569, find newermt issues impenetrable...

 
 

bug #44569: find newermt issues impenetrable diagnostic for ambiguous dates

Submitter:  Andrey Oliveira <andreyoliveira>
Submitted:  Wed 18 Mar 2015 02:04:33 PM UTC
 
Category:  find Severity:  3 - Normal
Item Group:  Wrong result Status:  Invalid
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.5.14 Fixed Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sat 28 Mar 2015 10:23:33 PM UTC, comment #2: 

While the date/time may indeed be ambiguous, this is a poor quality error message.   I would hope that can be more helpful to the user.   I will change the summary.

James Youngman <jay>
Project Administrator
Wed 18 Mar 2015 02:22:22 PM UTC, comment #1: 

This is not a bug in find.

https://www.gnu.org/software/coreutils/faq/coreutils-faq.html#The-date-command-is-not-working-right_002e

The find command shares the same date parser as used in coreutils' date(1) - and that parser honors daylight savings rules of your current locale.  As you apparently live in a locale where that specific date in October has no midnight (jumping straight from 23:59 on the previous day to 1:00 on that day), then the date you have specified really is bogus.  Try specifying a time that includes a safer hour, such as noon, that is unlikely to not exist due to daylight savings jumps, or try using TZ=UTC to force a time zone that doesn't have daylight savings issues.

Eric Blake <ericb>
Project Administrator
Wed 18 Mar 2015 02:04:33 PM UTC, original submission:  

The "find" has problems to work with some dates. Apparently one day in October every year.

Ex:

Command: find -maxdepth 1 -type f -newermt 2014-10-19

Result: find: I cannot figure out how to interpret '2014-10-19' as a date or time

Dates that have problems:

2011-10-16
2012-10-21
2013-10-20
2014-10-19
2015-10-18
2016-10-16

All other dates in the year has no problems.

Tested in Ubuntu, Slackware and Debian with findutils version in lastest stable packages, tested findutils 4.4.2 tarball and lastest 4.5.15-git from your git repository. All had the same problem.

Andrey Oliveira <andreyoliveira>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33388:  findbug.png added by andreyoliveira (94KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jay (Posted a comment)
  • -email is unavailable- added by ericb (Posted a comment)
  • -email is unavailable- added by andreyoliveira (Submitted the item)
  • -email is unavailable- added by andreyoliveira
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-03-28 jay Summaryfind newermt cannot figure out how to interpret some dates. find newermt issues impenetrable diagnostic for ambiguous dates
    2015-03-18 ericb StatusNone Invalid
        Open/ClosedOpen Closed
    2015-03-18 andreyoliveira Attached File- Added findbug.png, #33388
        Carbon-Copy- Added -email is unavailable-

    Back to the top


    Powered by Savane 3.9