bugGNU Octave - Bugs: bug #44440, "Add file to load path...

 
 

bug #44440: "Add file to load path dialog" gets triggered even if the file _is_ in the load path

Submitted by:  Lutz Mager <rocketsound>
Submitted on:  Fri 06 Mar 2015 12:01:20 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.0.0 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 02 Jun 2015 04:38:16 PM UTC, comment #6: 

Retagging release from 4.0.0-rc1 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Fri 06 Mar 2015 08:45:58 PM UTC, comment #5: 

I can call the function on the terminal widget as well as the CLI version, see attached screenshots. I altered the function a little bit, so it prints its own path.

With your workaround I can call the function via the editor widget, too.


Lutz Mager <rocketsound>
Fri 06 Mar 2015 06:15:37 PM UTC, comment #4: 

This report describes the same issue as bug #34731 which in turn is closed and marked as a duplicate of bug #31080.

Lutz, could you please double check if it is really possible to run the file from the command line?

Torsten Lilge <ttl>
Project Member
Fri 06 Mar 2015 05:48:06 PM UTC, comment #3: 

This really seems to be related to the root directory. Calling the function from the terminal window fails for me, too. A workaround is using

addpath ('c:\\.')

for adding the root directory to the search path. After that, calling the function works as expected.

Torsten Lilge <ttl>
Project Member
Fri 06 Mar 2015 05:17:51 PM UTC, comment #2: 

I can not reproduce this on my linux system and will test this on windows this evening. Is it just by accident or might the issue be related to the root directory 'C:' where your testfun.m is located. Can you add 'C:/' to the path?

Torsten Lilge <ttl>
Project Member
Fri 06 Mar 2015 12:16:54 AM UTC, comment #1: 

This also affects all the debug functions, for example via adding a breakpoint.

Lutz Mager <rocketsound>
Fri 06 Mar 2015 12:01:20 AM UTC, original submission:  

See attached screenshot, this only affects the editor widget. If I run

>> testfun(1)

from the command line/terminal widget everything works just fine (in GUI and also with the CLI). I don't know if this affects other OS, too, so I marked the bug report as specific to Windows.

Lutz Mager <rocketsound>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33270:  Screenshot.PNG added by rocketsound (28KiB - image/png)
file #33271:  Screenshot_2.PNG added by rocketsound (64KiB - image/png)
file #33253:  Screenshot.PNG added by rocketsound (116KiB - image/png)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by rocketsound (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-11-24 rik5 StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #31080
    2015-06-02 jwe Release4.0.0-rc1 => 4.0.0
    2015-03-06 rocketsound Attached File- => Added Screenshot.PNG, #33270
        Attached File- => Added Screenshot_2.PNG, #33271
    2015-03-06 rocketsound Attached File- => Added Screenshot.PNG, #33253

    Back to the top


    Powered by Savane 3.5