bugmake - Bugs: bug #43689, Make hangs in patsubst with...

 
 

bug #43689: Make hangs in patsubst with Japanese character

Submitted by:  None
Submitted on:  Tue 25 Nov 2014 02:06:28 AM UTC  
 
Severity:  3 - Normal Item Group:  Bug
Status:  Duplicate Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  4.0 Operating System:  POSIX-Based
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 12 Jul 2015 09:04:44 PM UTC, comment #4:

No reply so closed as a duplicate of bug #40371; please add a comment if you can still reproduce this with GNU make 4.1.

Paul D. Smith <psmith>
Project Administrator
Wed 26 Nov 2014 04:01:05 AM UTC, comment #3:

Maybe; bug #40371 was fixed in GNU make 4.1.  Please give that a try and see if that works...

Paul D. Smith <psmith>
Project Administrator
Wed 26 Nov 2014 02:41:15 AM UTC, comment #2:

I built 4.0 and it was working, but I don't know if this is compiler switch related.

Some debugging shows me that find_next_token is not able to make it through the third byte of utf8 sequence  0xe3 0x81 0x84
It basically fails at the STOP_SET macro.

Maybe it's related to this bug:
bug #40371: Make 4.0 is not 8 bit clean

Anonymous
Tue 25 Nov 2014 04:58:40 AM UTC, comment #1:

I've tried this on my GNU/Linux Mint 17 system with GNU make 3.82, 4.0, and the latest 4.1 and had no problems with any of them.  I think you may need to do more debugging yourself, if I can't reproduce it.

Paul D. Smith <psmith>
Project Administrator
Tue 25 Nov 2014 02:06:28 AM UTC, original submission:

I've attached the following (UTF8) encoded file:

INPUT := い.foo
#INPUT := 雨.foo

.PHONY=all

all :
@echo $(patsubst %.foo,%.bar,$(INPUT))

and it hangs and gnumake chews up 100% cpu.

GNU Make 4.0
Built for x86_64-unknown-linux-gnu

Linux jupiter 3.16.6-2-desktop #1 SMP PREEMPT Mon Oct 20 13:47:22 UTC 2014 (feb42ea) x86_64 x86_64 x86_64 GNU/Linux

Opensuse 13.2

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #32538:  Makefile added by None (97B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-07-12 psmith StatusNone => Duplicate
        Open/ClosedOpen => Closed
    2014-11-25 None Attached File- => Added Makefile, #32538

    Back to the top


    Powered by Savane 3.4