bugGNU Health - Bugs: bug #42809, Fails automatically set patient...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #42809: Fails automatically set patient and health professional

Submitted by:  Bruno M. Villasanti <bvillasanti>
Submitted on:  Sat 19 Jul 2014 01:28:33 AM UTC  
 
Category:  Functionality Severity:  4 - Important
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  Bruno M. Villasanti <bvillasanti>
Open/Closed:  Closed Release:  2.6.0
Module:  health

Sun 20 Jul 2014 07:14:16 PM UTC, comment #4: 

Reverted at changeset 1471:1e4ac29c0a8e

http://hg.savannah.gnu.org/hgweb/health/rev/1e4ac29c0a8e

Luis Falcon <meanmicio>
Project Administrator
Sun 20 Jul 2014 07:12:02 PM UTC, comment #3: 

This is a Tryton client issue[1] and not related to GNU Health.

1.- http://codereview.tryton.org/14391003/

Luis Falcon <meanmicio>
Project Administrator
Sat 19 Jul 2014 04:16:43 PM UTC, comment #2: 

Hello Bruno

I can't reproduce the bug.

In fact, we need the domain to have both person+patient or person+health_professional .

Works for me. Just saw on IRC that David could not reproduce it either.

Please revert push until we see what happened in your scenario.

Thanks

Luis Falcon <meanmicio>
Project Administrator
Sat 19 Jul 2014 01:38:07 AM UTC, comment #1: 

Fixed at changeset 1466:aeca38fff263

--
http://hg.savannah.gnu.org/hgweb/health/rev/aeca38fff263

Bruno M. Villasanti <bvillasanti>In charge of this item.
Sat 19 Jul 2014 01:28:33 AM UTC, original submission:  

When you create a new Party from the Patients form, it is not set correctly as "person" or "patient".

The same happens when creating Health Professionals.

Bruno M. Villasanti <bvillasanti>In charge of this item.

 

Attached Files
file #31743:  20140718-22:14:09.jpg added by bvillasanti (139KiB - image/jpeg - Bug)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by meanmicio (Posted a comment)
  • -email is unavailable- added by bvillasanti (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 11 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-07-20 meanmicio StatusWorks For Me => Invalid
        Open/ClosedOpen => Closed
    2014-07-19 meanmicio StatusInvalid => Works For Me
    2014-07-19 meanmicio StatusFixed => Invalid
        Open/ClosedClosed => Open
    2014-07-19 bvillasanti Attached File- => Added 20140718-22:14:09.jpg, #31743
    2014-07-19 bvillasanti Attached File#31742 => Removed
    2014-07-19 bvillasanti StatusIn Progress => Fixed
        Open/ClosedOpen => Closed
        ReleaseNone => 2.6.0
    2014-07-19 bvillasanti Attached File- => Added 20140718-22:14:09.jpg, #31742

    Back to the top


    Powered by Savane 3.7