bugGNU Health - Bugs: bug #41306, Alert appears when Posting...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #41306: Alert appears when Posting Invoices - Information needed

Submitted by:  Selvakumar <vselva>
Submitted on:  Wed 22 Jan 2014 02:42:49 PM UTC  
 
Category:  Demo environment Severity:  3 - Normal
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Release:  None
Module:  Invoice Post

Fri 24 Apr 2015 08:56:32 PM UTC, comment #1:

This is part of the financial module 'account' of tryton and is working correctly. The actual code can be examined here:

https://github.com/tryton/account/blob/develop/period.py

Basically, you have to define an accounting period in order to post an invoice: Fiscal Years > Fiscal Years > Periods. Undoubtedly we can add some better documentation, but this is not a bug per se. Personally, however, I'm not familiar with accounting so best practices and the meanings are mostly beyond me. Marking as invalid. Thanks though, shows we need better docs!

Chris Zimmerman <teffalump>
Project Member
Wed 22 Jan 2014 02:42:49 PM UTC, original submission:

I am testing GNU Health on demo server as following:
Server: health.gnusolidario.org:8000
Database: health24rc1
User name: admin
Password: gnusolidario
Tryton version: 3.0.2

When trying to Post an invoice it shows always
"No Period defined for date "01/22/2014"..
(Find attached screenshot)

I dont know what it says.
Searched net also.
Help not adequate.

Selvakumar <vselva>

 

Attached Files
file #30342:  gnuhealth-invoice-err.png added by vselva (217KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by teffalump (Posted a comment)
  • -email is unavailable- added by vselva (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-04-24 teffalump StatusNone => Invalid
        Open/ClosedOpen => Closed
    2014-01-22 vselva Attached File- => Added gnuhealth-invoice-err.png, #30342

    Back to the top


    Powered by Savane 3.3