bugfindutils - Bugs: bug #40803, ftsfind.1: \- changed to -...

 
 

bug #40803: ftsfind.1: \- changed to - (hyphen) in the name of an option

Submitter:  Bjarni Ingi Gislason <bjarniig>
Submitted:  Wed 04 Dec 2013 03:14:48 PM UTC
 
Category:  documentation Severity:  3 - Normal
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  jay
Originator Name:  Open/Closed:  Closed
Release:  4.5.12 Fixed Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sat 11 Jan 2014 02:23:56 PM UTC, comment #4: 

The minus sign is part of the name of the option itself.   The symbol in the option name is not a hyphen.

Marking this bug as invalid as that is the closest thing to "this is not a bug".

James Youngman <jay>
Project Administrator
Sun 05 Jan 2014 07:01:51 AM UTC, comment #3: 

On 2014-01-04 Bjarni Ingi Gislason wrote:
[...]

>  The hyphen-glyph is for the correct rendering of an
> English compound word, not the minus-glyph.  The '--' (rendered as
> two minus-glyphs) can be looked at as a kind of a prefix, to declare
> the (compound) name as an option.

[...]

>   People, that must (know nothing else) use copy-and-paste, should not
> use a command, that produces an output for a(n)
> (equivalent of) printed medium.  They should (may, must, shall) use an
> ASCII output, for example from the option '-T ascii' for 'man' (not
> sure) or try 'info ...'.  Or type it (learn to type
> with ten fingers) or use methods, that *NIX people have used, if they
> otherwise have to type repeatedly the same (long) command line.


>   Using "minus" (-) instead of a 'hyphen-minus' (-) (in a (compound) word) is
> just a pseudo solution.  It is based on ignorance.


I disagree quite strongly. Manpages are reference documention - "If you type exactly this then the following will happen". And find does not read/understand hyphens.

Also talking about unix tradition is not relevant here. This is a new problem which did not exist in the ancient days of yore, because terminals at this time could not render a hyphen and used minus signs automatically.

cu Andreas

Andreas Metzler <ametzler>
Sat 04 Jan 2014 08:51:07 PM UTC, comment #2: 

>You wrote:
> -.B \-\-without\-fts
> +.B \-\-without-fts


  In the mail, that I became, the following (equal) lines were present
(with Content-Type: text/plain;charset=UTF-8)

-.B --without-fts
+.B --without-fts

>The proposed change is broken.


  It is not for me.

> Find does not uses hyphens in options but minus signs.


 The hyphen-glyph is for the correct rendering of an
English compound word, not the minus-glyph.  The '\-\-' (rendered as
two minus-glyphs) can be looked at as a kind of a prefix, to declare
the (compound) name as an option.  The minus-glyph is more marked (in print,
with proportional fonts) than a hyphen, who is much shorter (in a
proportional font) than a minus.
 (The '\-' is the simplest way to get a dash, that is longer than a
hyphen.)

  People, that must (know nothing else) use copy-and-paste, should not
use a command, that produces an output for a(n)
(equivalent of) printed medium.  They should (may, must, shall) use an
ASCII output, for example from the option '-T ascii' for 'man' (not
sure) or try 'info ...'.  Or type it (learn to type
with ten fingers) or use methods, that *NIX people have used, if they
otherwise have to type repeatedly the same (long) command line.

  Using "minus" (\-) instead of a 'hyphen-minus' (-) (in a (compound) word) is just a pseudo solution.  It is based on ignorance.

Bjarni Ingi Gislason <bjarniig>
Wed 04 Dec 2013 06:11:18 PM UTC, comment #1: 

You wrote:
-.B \-\-without\-fts
+.B \-\-without-fts

The proposed change is broken. Find does not uses hyphens in options but minus signs.

http://lintian.debian.org/tags/hyphen-used-as-minus-sign.html

cu Andreas

Andreas Metzler <ametzler>
Wed 04 Dec 2013 03:14:48 PM UTC, original submission:  

  Change:

  \- in the name of an option changed to - (hyphen)

  Patch is in the attached file

Bjarni Ingi Gislason <bjarniig>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #29784:  ftsfind.1.diff added by bjarniig (388B - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jay (Posted a comment)
  • -email is unavailable- added by bjarniig (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-01-11 jay StatusNone Invalid
        Assigned toNone jay
        Open/ClosedOpen Closed
        Summaryftsfind.1: \\- changed to - (hyphen) in the name of an option ftsfind.1: \- changed to - (hyphen) in the name of an option
    2013-12-04 bjarniig Attached File- Added ftsfind.1.diff, #29784

    Back to the top


    Powered by Savane 3.9