bugGNU Octave - Bugs: bug #40498, opening or saving files crashes...

 
 

bug #40498: opening or saving files crashes the GUI on OSX

Submitted by:  Carlo de Falco <cdf>
Submitted on:  Wed Nov 6 21:23:10 2013  
 
Category: GUISeverity: 2 - Minor
Priority: 5 - NormalItem Group: None
Status: Wont FixAssigned to: None
Originator Name: Open/Closed: Closed
Release: devOperating System: Mac OS

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Thu Apr 14 15:55:14 2016, comment #12:

I think you're probably right. Mac OSX 10.9 was released in 10/13 which makes it 2.5 years old. We support some very old releases like Ubuntu 12.04, but we're also a very small team and I think we would just recommend that user's upgrade their OS.

Rik <rik5>
Project Administrator
Thu Apr 14 06:36:53 2016, comment #11:

Rik, comment #2 noted that this works with OSX 10.9.

My guess is that the issues with 10.7 and 10.8 are still present but not longer important.

I'm tentatively marking it as "Won't fix", but will leave it to someone more authoritative to close it.

Lachlan Andrew <lachlan>
Project Member
Sat Nov 21 05:13:08 2015, comment #10:

This bug is 2 years old. Is it still present? It seems that more people have been able to get Octave to run on OSX lately.

Rik <rik5>
Project Administrator
Tue Nov 19 21:22:24 2013, comment #9:

No, an editor without syntax highlighting seems equally pointless to me.

If I don't get back to you about this bug within a couple of days, then we'll just release a broken GUI, I guess.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Tue Nov 19 19:46:56 2013, comment #8:

Jordi, there is a workaround for this
issue which is downgrading qscintilla to 2.4.

with that octave-gui will not crash.
do you think this is enough to consider this bug as non-blocking
and proceed asynchronously with the release?

Carlo de Falco <cdf>
Project Member
Tue Nov 19 19:39:24 2013, comment #7:

I disagree.

I don't think there's a point in releasing without a working GUI on Windows and Mac OS X.

We should make this a blocking bug.

I'm working on this.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Mon Nov 18 20:48:25 2013, comment #6:

I agree to make it not blocking. To be honest, I have no idea what might cause the crash and I don't have a OSX-System available for testing. Sending test patches to Carlo is time consuming and not very effective.

Torsten <ttl>
Project Member
Mon Nov 18 19:21:42 2013, comment #5:

I'm not working on this anymore as I expect most
OSX users who are currently using OSX 10.8 to upgrade
to 10.9 eventually, so it's probably not worth the effort.

On the other hand the GUI can not be considered to be usable
on OSX 10.9 either due to bug #40545.

Carlo de Falco <cdf>
Project Member
Mon Nov 18 18:07:58 2013, comment #4:

I prefer to make it NOT blocking and note the issue.

Michael Godfrey <godfrey>
Mon Nov 18 17:54:18 2013, comment #3:

This bug is listed as a blocker for the 3.8 release, but I'm not sure any further progress is being made. Do you still want to work on this right now, or should we postpone it and put a note in the README.MacOS file that versions 10.7 and 10.8 are known not to work with the GUI?

Rik <rik5>
Project Administrator
Mon Nov 11 10:33:23 2013, comment #2:

I upgraded yesterday to Mavericks (OSX 10.9) and the editor crash does not occur anymore, so it appears this problem only affects OSX 10.8 and OSX 10.7.

Carlo de Falco <cdf>
Project Member
Thu Nov 7 07:33:24 2013, comment #1:

Here some mor informations:

The crash happens with QSintilla versions 2.6 or higher.

Attached a patch that strips most of the configurations of edit_area (the qscintilla editor). The remaining steps when loading an existing file related to _edit_area are:

+verbatim
_edit_area = new QsciScintilla; // in constructor

_edit_area->setText (in.readAll ()); // in load_file

QsciLexer *lexer = _edit_area->lexer (); // in update_lexer
delete lexer;
lexer = 0;
//... determine lexer from file extension
_edit_area->setLexer (lexer); // ---> crash
-verbatim-

A minimal example with those steps does not crash.

(file #29555)

Torsten <ttl>
Project Member
Wed Nov 6 21:23:10 2013, original submission:

a reproducible crash occurs in OSX in GUI mode.
to get the crash:

the crash happens in qscintilla::setLexer, therefore
disabling syntax highlighting in the sources is a workaround.

Carlo de Falco <cdf>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #29555:  qsci_2_6_mac.diff added by ttl (14kB - text/x-diff)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by lachlan (Posted a comment)
  • -unavailable- added by jordigh (Posted a comment)
  • -unavailable- added by godfrey (Posted a comment)
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by ttl (Updated the item)
  • -unavailable- added by cdf (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu Apr 14 15:55:14 2016rik5Open/ClosedOpen=>Closed
    Thu Apr 14 06:36:53 2016lachlanSeverity5 - Blocker=>2 - Minor
      StatusIn Progress=>Wont Fix
      Assigned tojordigh=>None
    Tue Nov 19 19:39:24 2013jordighSeverity3 - Normal=>5 - Blocker
      Assigned toNone=>jordigh
    Mon Nov 18 20:49:53 2013rik5Severity4 - Important=>3 - Normal
    Thu Nov 7 07:33:24 2013ttlAttached File-=>Added qsci_2_6_mac.diff, #29555

    Back to the top


    Powered by Savane 3.1-cleanup