bugGNU Octave - Bugs: bug #40473, Octave MinGW hangs on startup on...

 
 

bug #40473: Octave MinGW hangs on startup on Windows 8 64 bit

Submitted by:  None
Submitted on:  Mon 04 Nov 2013 06:07:59 PM UTC  
 
Category:  Configuration and Build System Severity:  2 - Minor
Priority:  1 - Later Item Group:  Installation Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Dov Kruger Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.6.4
Operating System:  Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 27 Mar 2014 04:55:22 AM UTC, comment #3:

Consensus seems to be that this is a duplicate of bug #37623. Marking as duplicate and closing.

Mike Miller <mtmiller>
Project Administrator
Wed 06 Nov 2013 09:26:54 PM UTC, comment #2:

Yes that is the way to get Octave to work on Win8.

From what I read in relevant threads on the maintainers ML this could be a gnulib issue.

As there is a fix => priority set to "later", & severity => minor

Item group => installation (something for an automated installer a la mxe-octave), & Category => "install & build"

Philip Nienhuis <philipnienhuis>
Project Member
Mon 04 Nov 2013 06:29:06 PM UTC, comment #1:

Have you read the README?

3. Copy octave3.6.4_gcc4.6.2.lnk to any convenient location and edit its properties respectively to point to <your_install_dir>\bin\octave.exe and <your_install_dir>\doc\octave\icons\octave-logo.ico as an icon

Note for windows 8 users: As a workaround for a gnulib windows 8 compatibility bug, add command line switches ' -i --line-editing' to the octave.exe shortcut (i.e. <octave-dir>\bin\octave.exe -i --line-editing)

Does this solve your problem?

Andreas Weber <andy1978>
Project Member
Mon 04 Nov 2013 06:07:59 PM UTC, original submission:

I have Octave working on a windows 7 machine, and didn't expect it to be different, but on my laptop, the package:

Octave3.6.4_gcc4.6.2_20130408.7z when unzipped to my usual:

c:\bin

all files are unpacked to:

c:\bin\octave\Octave3.6.4_gcc4.6.2

WHen I try to run:
c:\bin\octave\Octave3.6.4_gcc4.6.2\bin\octave

or
c:\bin\octave\Octave3.6.4_gcc4.6.2\bin\octave3.6.4

The window opens up but the program hangs.

I installed cygwin, and the machine does work with the version in the cygwin package. However, in order to get other people to load Octave, it would be a huge help not to have to load an entire operating system.

Is there any log file i can collect to help track this down?

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-03-27 mtmiller StatusConfirmed => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #37623
    2013-11-06 philipnienhuis CategoryOctave Forge Package => Configuration and Build System
        Severity3 - Normal => 2 - Minor
        Priority5 - Normal => 1 - Later
        Item GroupNone => Installation Failure
        StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.3