bugGNU Screen - Bugs: bug #40421, "Attach attempt with bad...

 
 

bug #40421: "Attach attempt with bad pid" multi-user screen on AIX 6.1

Submitted by:  None
Submitted on:  Tue 29 Oct 2013 06:42:02 PM UTC  
 
Category: Crash/Freeze/InfloopSeverity: 3 - Normal
Priority: 5 - NormalStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenRelease: 4.0.3
Fixed Release: NonePlanned Release: None
Work Required: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 29 Oct 2013 06:42:02 PM UTC, original submission:

When using screen so more than one user can interact on the same shell, the second user cannot connect to the screen session of the first user. "multi-user" and "addacl" commands have been executed. screen program is setuid to root to allow access.

The first user (who is trying to share their screen) sees the following message briefly:

"Attach attempt with bad pid(28573732)!"

Of course, the pid number changes. The second user's session just hangs. Nothing is shown.

This is screen version 4.00.03. This error occurs with AIX 6.1. The same version works in AIX 5.3.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

No Changes Have Been Made to This Item

Back to the top


Powered by Savane 3.1-cleanup