bugGNU Octave - Bugs: bug #40350, pager does not work on MacOSX (gui...

 
 

bug #40350: pager does not work on MacOSX (gui only)

Submitted by:  Ben Abbott <bpabbott>
Submitted on:  Tue 22 Oct 2013 05:44:25 PM UTC  
 
Category: GUISeverity: 4 - Important
Priority: 5 - NormalItem Group: Incorrect Result
Status: FixedAssigned to: John W. Eaton <jwe>
Originator Name: bpabbottOpen/Closed: Closed
Release: devOperating System: Mac OS

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sat 02 Nov 2013 01:49:51 AM UTC, comment #13:

I don't know what changed, but now the pager works correctly with both "help plot" and "history".

I'm closing the bug report.

Ben Abbott <bpabbott>
Project Member
Tue 29 Oct 2013 05:54:49 PM UTC, comment #12:

Ben, is the pager now working with jwe's break-up of octave into octave-gui, octave-cli, and octave (wrapper)? I'd love to close this bug.

Rik <rik5>
Project Administrator
Mon 28 Oct 2013 10:12:29 PM UTC, comment #11:

Thanks Carlo. Unfortunately, using your modified options makes no difference for me.

Ben Abbott <bpabbott>
Project Member
Mon 28 Oct 2013 06:18:46 PM UTC, comment #10:

Ben,

I'm now using slightly different configure options:

essentially I upgraded to llvm-3.3 and I added --without-x
to reduce dependencies for the app bundle, I am using the qt terminal by default as qt is already included in the bundle.

Carlo de Falco <cdf>
Project Member
Mon 28 Oct 2013 05:54:15 PM UTC, comment #9:

with the pacth sent by torsten in this thread:

http://octave.1599824.n4.nabble.com/Binary-packages-for-3-8-tp4658066p4658603.html

c.

Carlo de Falco <cdf>
Project Member
Mon 28 Oct 2013 05:38:53 PM UTC, comment #8:

Using Carlo's configure options under MacOSX with macports, I still encounter the crash. If I recall correctly, Carlo is running MacOS 10.8 while I'm running 10.7

Ben Abbott <bpabbott>
Project Member
Mon 28 Oct 2013 05:17:49 PM UTC, comment #7:

I'll do a maintainer-clean and then build using the configure options that Carlo has been using (included below).

I'll report back when done.

Ben Abbott <bpabbott>
Project Member
Mon 28 Oct 2013 04:25:11 PM UTC, comment #6:

It's very strange that the pager would work in some cases and not other.

hg id please?

John W. Eaton <jwe>
Project AdministratorIn charge of this item.
Mon 28 Oct 2013 04:08:16 PM UTC, comment #5:

I see a slightly different behaviour:
the pager works correctly for "help plot"
or "randn (1000, 1)".

If I type "history" typing q just produces a "q"
at the bottom of the command window.

history browsing in the gui has never worked for me,
with or without this patch.

c.

Carlo de Falco <cdf>
Project Member
Mon 28 Oct 2013 01:15:08 PM UTC, comment #4:

I reported on the mail-list that the pager was working for me now. Today I did some more testing.

The pager works for "help plot".

Unfortunately, when I type "history" something very wrong happens. The (f)orward and (b)ack work as expected. Typing (q)uit causes all Octave's Qt windows disappear. Octave does not exit, and the activity (task) manager indicates the CPU octave is running on is pegged at 100%.

Also the arrow keys do not allow me to browse the history.

Ben Abbott <bpabbott>
Project Member
Sun 27 Oct 2013 11:21:16 PM UTC, comment #3:

I checked in a changeset that I hope will fix this issue:

http://hg.savannah.gnu.org/hgweb/octave/rev/b5d58667d32d

If you build in a separate directory tree, you may need to edit the src/.deps/main.Po file so that it refers to the new main.cc file that is supposed to be generated in the build tree instead of the main.cc file that used to be in the source tree.

I'll follow up with more info on the mailing list.

John W. Eaton <jwe>
Project AdministratorIn charge of this item.
Thu 24 Oct 2013 07:35:58 AM UTC, comment #2:

I deleted the attached file because it was incomplete. I posted a better version on the mailing list thread.

John W. Eaton <jwe>
Project AdministratorIn charge of this item.
Thu 24 Oct 2013 05:55:32 AM UTC, comment #1:

I've added some more comments in the mailing list thread.

(file #29455)

John W. Eaton <jwe>
Project AdministratorIn charge of this item.
Tue 22 Oct 2013 05:44:25 PM UTC, original submission:

The pager does not work from the command window of the GUI. An email thread is below.

https://mailman.cae.wisc.edu/pipermail/octave-maintainers/2013-October/036737.html

The short story is that keystrokes in the command window of the gui have no effect since the keyboard remains connected to the terminal window used to originally launch Octave.

Ben Abbott <bpabbott>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by cdf (Posted a comment)
  • -unavailable- added by jwe (Updated the item)
  • -unavailable- added by bpabbott (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 02 Nov 2013 01:49:51 AM UTCbpabbottStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Thu 24 Oct 2013 05:55:45 AM UTCjweAttached File#29455=>Removed
    Thu 24 Oct 2013 05:55:32 AM UTCjweAttached File-=>Added driver.c, #29455
      Assigned toNone=>jwe
    Tue 22 Oct 2013 05:49:38 PM UTCbpabbottSummarypaper does not work on MacOSX (gui only)=>pager does not work on MacOSX (gui only)

    Back to the top


    Powered by Savane 3.1-cleanup