bugGNU TeXmacs - Bugs: bug #40317, Crash: hitting backspace in...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #40317: Crash: hitting backspace in document with preamble

Submitted by:  Miguel de Benito <mdbenito>
Submitted on:  Sun 20 Oct 2013 05:10:19 PM UTC  
 
Category: EditorPriority: 6 - Bit higher
Item Group: ErrorStatus: Wont Fix
Privacy: PublicAssigned to: Joris van der Hoeven <vdhoeven>
Originator Name: Open/Closed: Closed
Release: SVN 7570Release: None
Fixed Release: NoneFixed Release: 
Keywords: 

Thu 07 Nov 2013 09:09:59 AM UTC, comment #5:

This bug indeed has been fixed by me.

Joris van der Hoeven <vdhoeven>
Project AdministratorIn charge of this item.
Thu 07 Nov 2013 09:07:03 AM UTC, comment #4:

On which platform did you experienced the bug, Miguel ?

Francois Poulain <fpoulain>
Project Member
Wed 06 Nov 2013 07:15:48 PM UTC, comment #3:

I can not reproduce the bug on my side (latest svn version with Ubuntu).

Lebreton Romain <lebreton>
Project Member
Thu 24 Oct 2013 02:46:21 PM UTC, comment #2:

Yes. A fresh build, after cleaning and running --setup (or Option+click in my case).

Miguel de Benito <mdbenito>
Project Member
Wed 23 Oct 2013 08:17:28 AM UTC, comment #1:

Hi,

It works for me. Can you reproduce it after a "make clean" ?

Francois Poulain <fpoulain>
Project Member
Sun 20 Oct 2013 05:10:19 PM UTC, original submission:
  • Open TeXmacs
  • Document->Part->Create preamble
  • Document->Part->Show all parts
  • Hit backspace
  • Crash

The console says:

which is printed because at pager_rep::papyrus_make(), break_pages() returns an empty "skeleton".

Miguel de Benito <mdbenito>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vdhoeven (Posted a comment)
  • -unavailable- added by lebreton (Posted a comment)
  • -unavailable- added by mdbenito (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 07 Nov 2013 09:11:25 AM UTCvdhoevenStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Sun 20 Oct 2013 05:10:41 PM UTCmdbenitoPriority5 - Normal=>6 - Bit higher

    Back to the top


    Powered by Savane 3.1-cleanup