bugGnash - The GNU Flash player - Bugs: bug #39949, ofla_demo.swf: disconnect doesn't...

 
 

bug #39949: ofla_demo.swf: disconnect doesn't work

Submitted by:  Gabriele Giacone <gg0>
Submitted on:  Wed Sep 4 23:21:17 2013  
 
Category: RTMP and AMFSeverity: 3 - Normal
Release: NoneStatus: In Progress
Privacy: PublicAssigned to: George Thomas <georgethomas>
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat Sep 14 08:17:39 2013, comment #4:

This is not fixed with the patch I sent. Need to work a bit more to fix this issue.

The last patch primarily was about re factoring the code.

I have to spent a bit of time to get this one fixed.

George Thomas <georgethomas>
Project MemberIn charge of this item.
Sat Sep 14 08:14:42 2013, comment #3:

Should be fixed in master:
http://git.savannah.gnu.org/cgit/gnash.git/commit/?id=f246e38aa4723afe397b23f52b489391a17419b5

Please test

Sandro Santilli <strk>
Project Member
Thu Sep 5 13:26:04 2013, comment #2:

too many bugs in a single ticket :>
The text one sounds like related to region-invalidation (but I could be wrong)

Sandro Santilli <strk>
Project Member
Thu Sep 5 12:18:03 2013, comment #1:

Checking wireshark with oflaDemo in gnash, the packets are coming with the data, fullName and size.

The issue should be in the way the data is consumed once its received.

Looks like the curl streams are not getting removed when the destructor for netStream is going out of scope.

I can look into it.

George Thomas <georgethomas>
Project MemberIn charge of this item.
Wed Sep 4 23:21:17 2013, original submission:

http://gnashdev.org:5080/demos/ofla_demo.swf [AVM1 SWF7]

Replace localhost with gnashdev.org and click on "connect".

library should display all available movies but both column headers and table elements names only show initial letter.
If you move vertical bar, elements names get fixed, even better if you click on column headers to sort them.

Then by clicking on one element/row, movie starts playing. George's patch does work.

Last glitch is that by clicking "disconnect", it doesn't actually disconnect.
Playing movie doesn't stop as it should and logs say it keeps sending keepalive(?) packets:
16280:1] 159734 DEBUG: Received <control packet>
16280:1] 159734 DEBUG: Received control packet <ping> with argument -348611094
16280:1] 159734 DEBUG: Sending control type 7 <pong>
16280:1] 161754 DEBUG: Received <control packet>
16280:1] 161755 DEBUG: Received control packet <ping> with argument -348609093
16280:1] 161755 DEBUG: Sending control type 7 <pong>

Gabriele Giacone <gg0>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by strk (Posted a comment)
  • -unavailable- added by georgethomas (Posted a comment)
  • -unavailable- added by gg0 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun Sep 15 16:12:56 2013strkStatusReady For Test=>In Progress
    Sat Sep 14 08:14:42 2013strkStatusNone=>Ready For Test
    Thu Sep 5 14:10:16 2013gg0CategoryNone=>RTMP and AMF
      Summaryofla_demo.swf glitches=>ofla_demo.swf: disconnect doesn't work
    Thu Sep 5 12:30:17 2013georgethomasAssigned toNone=>georgethomas

    Back to the top


    Powered by Savane 3.1-cleanup