bugGNU Octave - Bugs: bug #39816, openmpi_ext 1.1.0 not compatible...

 
 

bug #39816: openmpi_ext 1.1.0 not compatible with OpenMPI 1.6

Submitted by:  None
Submitted on:  Mon 19 Aug 2013 04:04:04 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Build Failure
Status: DuplicateAssigned to: None
Originator Name: Originator Email: -unavailable-
Open/Closed: ClosedRelease: other
Operating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 25 Aug 2013 04:15:50 PM UTC, comment #2:

Duplicate of patch #8169.

Carnë Draug <carandraug>
Project Member
Mon 19 Aug 2013 04:05:22 PM UTC, comment #1:

Oops I forgot to login before submitting the bug report. So you now have my identity.

Sébastien Villemot <svillemot>
Mon 19 Aug 2013 04:04:04 PM UTC, original submission:

When building openmpi_ext package against OpenMPI 1.6, one gets:

The problem is that some private fields of some MPI structure are used, and one changed its name.

I attach a patch that fixes the issue. You may want to adapt the patch to make the code compile on both the old and the new version of OpenMPI.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #28876:  openmpi-1.6.patch added by None (546B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by svillemot (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 23 Oct 2013 09:55:37 PM UTCcarandraugStatusNone=>Duplicate
      Open/ClosedOpen=>Closed
    Mon 19 Aug 2013 04:04:04 PM UTCNoneAttached File-=>Added openmpi-1.6.patch, #28876

    Back to the top


    Powered by Savane 3.1-cleanup