bugGNU Octave - Bugs: bug #38965, cirrcshift giving incorrect result

 
 

bug #38965: cirrcshift giving incorrect result

Submitted by:  Glenn Jolly <stargazerx5>
Submitted on:  Sat 11 May 2013 08:30:32 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Incorrect Result
Status: InvalidAssigned to: None
Originator Name: Open/Closed: Closed
Release: 3.6.4Operating System: Microsoft Windows

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 12 May 2013 10:29:00 PM UTC, comment #4:

Happens in the best of families. It's a pity that we have to copy Matlab's lack of namespaces:

http://abandonmatlab.wordpress.com/2010/05/30/the-mathworks-doesnt-even-know-how-to-look-up-functions-in-their-own-global-namespace/

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Sun 12 May 2013 09:59:50 PM UTC, comment #3:

Disregard this bug report, my apologies for the confusion. I had a vector circshift in the same test directory.

Glenn Jolly <stargazerx5>
Sun 12 May 2013 02:05:52 PM UTC, comment #2:

This is quite bizarre. What does "which circshift" say? Can you show the output of "type circshift"?

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Sun 12 May 2013 02:01:01 PM UTC, comment #1:

I cannot reproduce with 3.6.3 or 3.7.3+ on Linux, and circshift.m has not changed at all between those versions. And I think it would not even pass the tests with the behavior you describe.

I will have to try on my Windows machine tomorrow.

Clemens Buchacher <drizzd>
Sat 11 May 2013 08:30:32 PM UTC, original submission:

circshift of an array returns a vector:

x = [1, 2, 3; 4, 5, 6; 7, 8, 9];
x1 = circshift (x, 1)
x1 =

7 1 4

and not the expected

x1 =

7 8 9
1 2 3
4 5 6

this is the cygwin octave 3.6.4 behavior. An older release (2008) of circshift is working as expected.

Glenn Jolly <stargazerx5>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by jordigh (Posted a comment)
  • -unavailable- added by drizzd (Posted a comment)
  • -unavailable- added by stargazerx5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 12 May 2013 10:29:00 PM UTCjordighStatusNeed Info=>Invalid
      Open/ClosedOpen=>Closed
    Sun 12 May 2013 02:05:52 PM UTCjordighStatusNone=>Need Info

    Back to the top


    Powered by Savane 3.1-cleanup