bugGNU Octave - Bugs: bug #38209, axis label and legend positions...

 
 

bug #38209: axis label and legend positions are not updated in figure when manually changed (gnuplot)

Submitted by:  None
Submitted on:  Wed 30 Jan 2013 11:57:16 PM UTC  
 
Category:  Plotting with gnuplot Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Wont Fix Assigned to:  Ben Abbott <bpabbott>
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  dev
Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 19 Jul 2013 03:20:47 PM UTC, comment #2:

Many of the legend properties have no effect on the legend. That is because we use the gnuplot's keybox to produce the legend.

The keybox is used because Octave is unable to determine the extents and positions of the text objects used by gnuplot.

The 3.6.1 series is done, so I'm changing the release to "dev" and marking the status as "Wont Fix".

Ben Abbott <bpabbott>
Project MemberIn charge of this item.
Thu 31 Jan 2013 04:15:46 PM UTC, comment #1:

Confirmed on both the stable and development branches of Octave.

I'm not sure how much urgency there will be to fix this since Octave development is shifting away from using gnuplot as the back end for graphics.

Rik <rik5>
Project Administrator
Wed 30 Jan 2013 11:57:16 PM UTC, original submission:

The axis label and legend positions are not updated in figure when they are manually changed using the method in the code below.

I'm using gnuplot 4.6 patchlevel 1, but got the same result with version 4.2.6-1. Operating system is kubutu 10.04.

The correct result is achieved with the fltk backend.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bpabbott (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-12-22 rik5 Summaryaxis label and legend positions are not updated in figure when manually changed => axis label and legend positions are not updated in figure when manually changed (gnuplot)
    2013-07-28 bpabbott Open/ClosedOpen => Closed
    2013-07-19 bpabbott StatusConfirmed => Wont Fix
        Assigned toNone => bpabbott
        Release3.6.1 => dev
        Operating SystemGNU/Linux => Any
    2013-01-31 rik5 StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.3