bugGNU Screen - Bugs: bug #38201, Autoconf error

 
 

bug #38201: Autoconf error

Submitted by:  None
Submitted on:  Wed 30 Jan 2013 07:41:28 AM UTC  
 
Category:  Build/Install Severity:  3 - Normal
Priority:  5 - Normal Status:  Confirmed
Privacy:  Public Assigned to:  Alexander Naumov <anaumov>
Open/Closed:  Closed Release:  Cur Dev Sources
Fixed Release:  None Planned Release:  None
Work Required:  None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 03 Jun 2015 10:01:39 PM UTC, comment #1:

Yes, it looks like Scientific_Linux_5.8 has autoconf-2.59-12 [1], but the macro AC_USE_SYSTEM_EXTENSIONS was added to autoconf since version 2.60 [2].

So... just update autoconf and have a lot of fun ;-)

Your patch is already in git.

Thank you for contribute,
Alex

[1] http://ftp.scientificlinux.org/linux/slf58/x86_64/SL/
[2] https://www.gnu.org/software/autoconf/manual/autoconf.html#Posix-Variants

Alexander Naumov <anaumov>
Project AdministratorIn charge of this item.
Wed 30 Jan 2013 07:41:28 AM UTC, original submission:

Running autogen.sh gives the following error.

$ > ./autogen.sh
configure.in:48: error: possibly undefined macro: AC_USE_SYSTEM_EXTENSIONS
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

This is with commit cbaa666 and:

$ > cat /proc/version
Linux version 2.6.18-308.20.1.el5 (brewbuilder@norob.fnal.gov) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-52)) #1 SMP Tue Nov 13 11:54:02 EST 2012

$ > cat /etc/issue
Scientific Linux release 5.8 (Boron)
Kernel \r on an \m

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #32537:  0001-Add-AC_PREREQ-to-specify-min-autoconf-version.patch added by None (735B - application/octet-stream - This patch fixes autoconf issues on Debian/Ubuntu, and should cause older incompatible autoconf versions to present a reasonable error message.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by anaumov (Updated the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-06-03 anaumov StatusNone => Confirmed
        Open/ClosedOpen => Closed
    2015-06-03 anaumov Assigned toNone => anaumov
    2014-11-24 None Attached File- => Added 0001-Add-AC_PREREQ-to-specify-min-autoconf-version.patch, #32537

    Back to the top


    Powered by Savane 3.3