bugGNU Parallel - build and execute command lines from standard input in parallel - Bugs: bug #38110, parallel --pipe not very parallel

 
 

bug #38110: parallel --pipe not very parallel

Submitted by:  None
Submitted on:  Thu 17 Jan 2013 09:53:38 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: Wont Fix
Privacy: PublicAssigned to: Ole Tange <tange>
Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 24 Jan 2013 11:45:08 PM UTC, comment #1:

$ seq 10000 | wc
10000 10000 48894

48894 is less than default --block-size (1M), so the behaviour is as expected: Spawn only one.

Not a bug.

Ole Tange <tange>
Project AdministratorIn charge of this item.
Thu 17 Jan 2013 09:53:38 PM UTC, original submission:

Before commit bbc9a53ea5fc746a0a3ef7e8733dfcd61ff05eea

seq 10000 |src/parallel --pipe -j24 sleep 10

would spawn 24 processes as counted by something like

pgrep sleep | wc

After aforementioned commit, only 1 process is spawned.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by tange (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 24 Jan 2013 11:45:08 PM UTCtangeStatusNone=>Wont Fix
      Assigned toNone=>tange
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup