bugGNU gettext - Bugs: bug #37851, configure.ac - autoconf errs on...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #37851: configure.ac - autoconf errs on incomplete call to AC_INIT

Submitter:  None
Submitted:  Sat 01 Dec 2012 05:37:03 PM UTC
 
Category:  Build Severity:  3 - Normal
Item Group:  None Status:  Not a Bug
Privacy:  Public Assigned to:  ueno
Open/Closed:  Closed
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Mon 12 Dec 2016 01:56:31 AM UTC, comment #2: 
Bruno Haible <haible>
Project Administrator
Mon 17 Dec 2012 09:35:50 AM UTC, comment #1: 

I couldn't reproduce this with the bundled autogen.sh, which supplies "-I m4" to aclocal.

As far as I look at m4/init-package-version.m4, the AC_INIT diagnosis code in automake's init.m4 shouldn't be pulled.

Feel free to reopen if this is not the case.

Daiki Ueno <ueno>
Project Administrator
Sat 01 Dec 2012 05:37:03 PM UTC, original submission:  

autogen.sh fails to produce a usable configure script :

gettext $ ./configure
./configure: line 1764: syntax error near unexpected token `gettext,'
./configure: line 1764: `gl_INIT_PACKAGE(gettext, $VERSION_NUMBER)'

System specs: OSX 10.6 (darwin 10.8.0), gcc 4.2.1, autoconf 2.69, automake 1.12.5

When more closely inspected:

$ aclocal
configure.ac:25: error: AC_INIT should be called with package and version arguments

Fixed by the attached patch.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #27015:  gettext-ac.diff added by None (547B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Updated the item)
  • -email is unavailable- added by ueno (Posted a comment)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-27 haible CategoryNone Build
        Assigned toNone ueno
    2012-12-17 ueno StatusNone Not a Bug
        Open/ClosedOpen Closed
    2012-12-01 None Attached File- Added gettext-ac.diff, #27015

    Back to the top


    Powered by Savane 3.9