bugGNU TeXmacs - Bugs: bug #37668, TeXmacs doesn't compile with clang...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #37668: TeXmacs doesn't compile with clang under Linux

Submitted by:  Francois Poulain <fpoulain>
Submitted on:  Mon 05 Nov 2012 12:44:24 PM UTC  
 
Category: CompilationPriority: 3 - Low
Item Group: ErrorStatus: Invalid
Privacy: PublicAssigned to: Francois Poulain <fpoulain>
Originator Name: Open/Closed: Closed
Release: Release: None
Fixed Release: NoneFixed Release: 
Keywords: 

Thu 28 Nov 2013 09:41:08 AM UTC, comment #5:

Yes, I agree. Since I have no time for this at the moment, I close the bug and I note in my head to kill this warning some day.

Francois Poulain <fpoulain>
Project MemberIn charge of this item.
Thu 28 Nov 2013 09:25:04 AM UTC, comment #4:

I regularly compile using clang under MacOS without trouble, so this might be because of ABI incompatibilities. I haven't checked the logs, but maybe Qt was linked with libstdc++ and you are linking against libc++?

As to the warnings, I agree. I have hundreds, many of which are easily fixed.

Miguel de Benito <mdbenito>
Project Member
Thu 28 Nov 2013 08:45:58 AM UTC, comment #3:

It fails at linking level. But I don't know if it's a bug of TeXmacs. I attach the complete compilation log and the config.log.

There are also many warns which should be checked and corrected.

(file #29723, file #29724)

Francois Poulain <fpoulain>
Project MemberIn charge of this item.
Wed 27 Nov 2013 09:59:24 PM UTC, comment #2:

I think that Gregoire managed to compile with clang. Please close this bug if it is no longer present.

Joris van der Hoeven <vdhoeven>
Project Administrator
Mon 25 Feb 2013 10:15:07 AM UTC, comment #1:

Can you post the compilation warnings? Seems that something is wrong with name-mangling maybe.

Massimiliano Gubinelli <mgubi>
Project Administrator
Mon 05 Nov 2012 12:44:24 PM UTC, original submission:

Hi,

TeXmacs doesn't compile with clang.

During compilation, a lot of warning are generated but it seems inoffensive. However, at linking time, many symbols are unfound. The problem seems to be due to the Qt part.

Here is joint an error log.

Francois Poulain <fpoulain>
Project MemberIn charge of this item.

 

Attached Files
file #29723:  config.log added by fpoulain (65kB - text/x-log)
file #29724:  error.log added by fpoulain (467kB - text/x-log)
file #26877:  clang_compilation.log added by fpoulain (322kB - text/x-log)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vdhoeven (Posted a comment)
  • -unavailable- added by mgubi (Posted a comment)
  • -unavailable- added by mdbenito (Updated the item)
  • -unavailable- added by fpoulain (Submitted the item)
  • -unavailable- added by fpoulain
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 10 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 28 Nov 2013 09:41:08 AM UTCfpoulainStatusConfirmed=>Invalid
      Open/ClosedOpen=>Closed
    Thu 28 Nov 2013 08:45:58 AM UTCfpoulainAttached File-=>Added config.log, #29723
      Attached File-=>Added error.log, #29724
    Wed 27 Nov 2013 09:59:24 PM UTCvdhoevenAssigned toNone=>fpoulain
    Tue 13 Nov 2012 10:21:51 PM UTCmdbenitoPriority5 - Normal=>3 - Low
      Item GroupNone=>Error
      SummaryTeXmacs doesn\'t compile with clang=>TeXmacs doesn't compile with clang under Linux
    Mon 05 Nov 2012 12:44:24 PM UTCfpoulainAttached File-=>Added clang_compilation.log, #26877
      Carbon-Copy-=>Added grĂ©goire lecerf

    Back to the top


    Powered by Savane 3.1-cleanup