bugGNUstep - Bugs: bug #37609, GSXML.m (gnustep-base) does not...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #37609: GSXML.m (gnustep-base) does not build against libxml2-2.9.0 (patch included)

Submitted by:  Rene Hexel <rhx>
Submitted on:  Sun 21 Oct 2012 11:39:38 PM UTC  
 
Category:  Base/Foundation Severity:  3 - Normal
Item Group:  Bug Status:  Fixed
Privacy:  Public Assigned to:  None
Open/Closed:  Closed

Mon 22 Oct 2012 04:23:10 AM UTC, comment #1:

Thanks very much ... I applied that patch to svn trunk.

Richard Frith-Macdonald <CaS>
Project Member
Sun 21 Oct 2012 11:39:38 PM UTC, original submission:

The content and use fields have become private and are only exposed through xmlBufContent() and xmlBufUse() since libxml-2.9.0. The attached patch (against gnu step-base-1.24.0) uses those macros for newer versions of libxml to make gnustep-base compile again.

Rene Hexel <rhx>

 

Attached Files
file #26812:  patch-af added by rhx (465B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by CaS (Posted a comment)
  • -email is unavailable- added by rhx (Submitted the item)
  • -email is unavailable- added by rhx
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-10-22 CaS StatusNone => Fixed
        Open/ClosedOpen => Closed
    2012-10-21 rhx Attached File- => Added patch-af, #26812
        Carbon-Copy- => Added rhx

    Back to the top


    Powered by Savane 3.3