bugGNUstep - Bugs: bug #37202, Lock broken

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #37202: Lock broken

Submitted by:  Germán Arias <espectador>
Submitted on:  Mon 27 Aug 2012 04:54:56 AM UTC  
 
Category: LibrariesSeverity: 3 - Normal
Item Group: BugStatus: Invalid
Privacy: PublicAssigned to: None
Open/Closed: Closed

Fri 07 Sep 2012 08:11:25 PM UTC, comment #3:

Closed as requested by original author

Fred Kiefer <FredKiefer>
Project Member
Fri 07 Sep 2012 05:58:36 AM UTC, comment #2:

Well, after more test I found the problem. This is not a bug on GNUstep, is a bug on WindowMaker versions 0.95.2 and 0.95.3. I have some months using only WindowMaker, but after test gnustep on Gnome 3 and Xfce I have no problem. Back to WindowMaker I removed all gnustep apps from dock and the problem is gone. I think the problem is that sometimes the dock launch a second instance of the app just after launch the first instance and this is causing this problem. Anyway I will report this issue.

So, you can decline this bug because isn't really a bug.

Germán Arias <espectador>
Wed 05 Sep 2012 07:01:26 PM UTC, comment #1:

According with Cocoa documentation:

https://developer.apple.com/library/mac/#documentation/Cocoa/Reference/Foundation/Classes/NSDistributedLock_Class/Reference/Reference.html

-unlock: only raises an exception if the target doesn't exist. However, is not clear if always succeed.

One solution, in the side of NSWorkspace, is check if the conditions (attributes, locktime) allow unlock. Or maybe handle each app in its own file, as NSUserDefaults handle the defaults for each app (in separated .plist files).

Germán Arias <espectador>
Mon 27 Aug 2012 04:54:56 AM UTC, original submission:

Sometimes when launch an app, I get:

NSGenericException: lock
'/tmp/GNUstepSecure1000/GSLaunchedApplications.lock' already broken

I do something like:

1) Run many gnustep apps.
2) Then close some of these apps.
3) Interact with non gnustep's apps
4) Run others gnustep apps.
5) Launch again some gnustep apps.
6) Then close some gnustep apps.
7) ...

At some point I get this error. I don't know if this problem is caused by recent changes in Base. Or if is caused by NSWorkspace class (maybe the code in this class isn't according with recent changes in Base).

For the moment I comment out some blocks of code in NSDistributedLock.m for solve my problem.

Germán Arias <espectador>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by FredKiefer (Posted a comment)
  • -unavailable- added by espectador (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 07 Sep 2012 08:11:25 PM UTCFredKieferStatusNone=>Invalid
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup