bugGNU gettext - Bugs: bug #35734, Compile failure in...

 
 

bug #35734: Compile failure in gettext-runtime/intl/relocatable.c

Submitted by:  Peter Seiderer <pseiderer>
Submitted on:  Tue 06 Mar 2012 07:39:05 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: Not a Bug
Privacy: PublicAssigned to: None
Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 05 May 2014 11:39:13 PM UTC, comment #3:

I think it is a GDB specific issue. relocatable.c depends on relocatable-lib.m4, which comes from the relocatable-lib Gnulib module:
https://gnu.org/software/gnulib/manual/html_node/Supporting-Relocation.html#Supporting-Relocation
and the file and the gl_RELOCATABLE_LIBRARY call are missing from the GDB source.

However, since the relocatable stuff does not seem to be used in GDB, maybe the easiest way is to just supply INSTALLPREFIX from the compiler command line?

(Closing for gettext now)

Daiki Ueno <ueno>
Project Administrator
Mon 05 May 2014 09:56:50 PM UTC, comment #2:

Checked with gettext-0.18.3.2, INSTALLPREFIX is supplied through config.h.

But INSTALLPREFIX is not supplied in the gdb-7.4 packed intl version (see link on busybox/buildroot bug report).

And INSTALLPREFIX is not supplied in my version (git version from two years ago 0c5051a4709e3418091e5961a630f9955b58edda) after running autogen.sh. I do not know what makes the difference, autoconf/autoheader version?

Peter Seiderer <pseiderer>
Fri 02 May 2014 10:02:03 AM UTC, comment #1:

If I understand correctly, INSTALLPREFIX is implicitly supplied through config.h. Isn't it sufficient?

Daiki Ueno <ueno>
Project Administrator
Tue 06 Mar 2012 07:39:05 PM UTC, original submission:

In case of PIC, INSTALLDIR and ENABLE_COSTLY_RELOCATABLE set, there needs to be INSTALLDIR and INSTALLPREFIX to be set/defined, but gettext-runtime/intl/Makefile.in fails to do so for INSTALLPREFIX.

Hit this case with buildroot and gdb-7.4 (containing a old version of intl), see https://bugs.busybox.net/show_bug.cgi?id=4868

Suggested patch attached.

Peter Seiderer <pseiderer>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by ueno (Posted a comment)
  • -unavailable- added by pseiderer (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 05 May 2014 11:39:13 PM UTCuenoStatusNone=>Not a Bug
      Open/ClosedOpen=>Closed
    Tue 06 Mar 2012 07:39:05 PM UTCpseidererAttached File-=>Added gettext-fix-intl-relocation-compile.patch, #25278

    Back to the top


    Powered by Savane 3.1-cleanup