bugGNU GRUB - Bugs: bug #35667, error: unknown filesystem. grub...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #35667: error: unknown filesystem. grub rescue> after Ubuntu 11.10 install

Submitted by:  Tranas Spietis <tranas>
Submitted on:  Wed 29 Feb 2012 02:59:20 PM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: InvalidPrivacy: Public
Assigned to: NoneOriginator Name: Cannonical
Open/Closed: ClosedRelease: 
Release: otherReproducibility: Every Time
Planned Release: None

(Jump to the original submission Jump to the original submission)

Sun 03 Jun 2012 12:51:38 PM UTC, comment #11:

The reporter failed to provide the requested info (output of "ls -l" and whether grub-fstest and grub-probe work), instead supplying loads of irrelevant unrequested info. Since there is a plausible explanation (BIOS limit) and workaround (--disk-module), closing the bug report.

Vladimir Serbinenko <phcoder>
Project Administrator
Sun 04 Mar 2012 01:19:57 AM UTC, comment #10:

The storage controller isn't a problem either. Possible source of problem is BIOS, not controller. Which filesystem is it? Do grub-fstest and grub-probe work?

Vladimir Serbinenko <phcoder>
Project Administrator
Thu 01 Mar 2012 03:31:43 AM UTC, comment #9:

Belarc reports the storage controller on this machine to be an
Intel 82801CAM Utra ATA Storage controller-248A
SIW shows the same controller

From the Intel® 82801CA I/O Controller Hub 3-S: Datasheet -
• Integrated IDE controller supports Ultra ATA100/66/33

From the ATA-ATAPI-6 documentation-

• standard
ATA/ATAPI-6, ATA-6, Ultra ATA/100
• transfer modes
UDMA 5, aka UDMA/100
• maximum disk size
128 PiB (144 PB)
• features
48-bit LBA, Device Configuration Overlay (DCO), Automatic Acoustic Management (AAM)

Tranas Spietis <tranas>
Wed 29 Feb 2012 07:04:43 PM UTC, comment #8:

None of software you mentioned uses BIOS for accessing disks

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 29 Feb 2012 06:59:51 PM UTC, comment #7:

Seems the issue is the inability of Grub2 to access the files.

Read the output of root@PartedMagic:~# fdisk -l

All the following have no issue accessing the full 250 GB drive -

XP
Ubuntu
Linux Terminal
Acronis True Image
Acronis Disk Director
Rescatux
boot-repair-disk
Gparted
Clonezilla

NONE throw an error: unknown filesystem. Grub2 does.

Tranas Spietis <tranas>
Wed 29 Feb 2012 06:23:04 PM UTC, comment #6:

Some BIOS are limited to some particular disk size, usually 128GiB. You can check this by booting into a working GRUB (e.g. on external storage and issuing ls -l and compare reported disk size with real one)

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 29 Feb 2012 06:20:11 PM UTC, comment #5:

I would also point out, that this particular machine has used Acronis TrueImage v8.0 build 937 since it was released - and Acronis has no issues with the BIOS. As I understand it, Acronis is essentially Linux code - rewrites the MBR when creating and restoring partition images from within Windows. Gparted from withing PartedMagic also has no issues resizing, formatting, setting flags or designating the boot partition - be it linux, swap or ntfs.

Possibly something that Cannonical does with Grub2??

Tranas Spietis <tranas>
Wed 29 Feb 2012 06:03:38 PM UTC, comment #4:

Possibly you can direct me on how to determine if this particular BIOS is "buggy"?

There is only 1 later BIOS version -
2.10 - but the update does not appear to apply to boot
- (New) Support IBM 11bg Wireless LAN Mini PCI Adapter.

Property Value
BIOS Vendor IBM
BIOS Version 1IET70WW (2.09 )
Firmware Version 77.0
BIOS Date 08/08/2005
BIOS Size 1024 KB
BIOS Starting Segment DC00h
DMI Version 2.31
Characteristics - supports PCI
- supports PC Card (PCMCIA)
- supports Plug-and-Play
- supports APM
- upgradeable (Flash) BIOS
- allows BIOS shadowing
- ESCD support is available
- supports booting from CD-ROM
- supports selectable boot
- supports booting from PC Card (PCMCIA)
- supports Enhanced Disk Drive specification
- supports INT 13 3.5-inch/720K floppy services
- supports INT 05 print-screen
- supports INT 09 and 8042 keyboard services
- supports INT 14 serial services
- supports INT 17 printer services
- supports INT 10 CGA/Mono video services
- supports ACPI
- supports AGP
- supports booting from LS-120
- BIOS Boot Specification supported

Tranas Spietis <tranas>
Wed 29 Feb 2012 04:41:58 PM UTC, comment #3:

Yes, it is default but it's unsuitable for some buggy BIOSes.

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 29 Feb 2012 03:33:20 PM UTC, comment #2:

No, I have not.

Thought that the MBR was easiest/most convential setup.

Seems to be the default in most cases.

Tranas Spietis <tranas>
Wed 29 Feb 2012 03:11:55 PM UTC, comment #1:

Have you tried making a separate /boot at the beginning of the disk?

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 29 Feb 2012 02:59:20 PM UTC, original submission:

error after a fresh dual boot install of Ubuntu 11.10 on a WinXP Thinkpad laptop - fixboot+fixmbr will repair MBR and allow windows to boot.

Single disk, no raid.

Used boot-repair-disk
Executed the 1 click recommended repair
Executed the "Purge and reinstall" option
neither resolves the issue

Filed bug report
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/929322

repartitioned disk with 4 primary partitions - repeat install of Ubuntu 11.10 - same error message

Used RescaTux
Executed Restore Grub
Executed Update Grub
neither resolves the issue

http://paste.debian.net/158029/
http://paste.debian.net/158030/

PartedMagic has no problem reading the Linux partition [sda3]
fully functional from RAM

Welcome - Parted Magic (Linux 3.1.6-pmagic)

root@PartedMagic:~# fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9d6525c0

Device Boot Start End Blocks Id System
/dev/sda1 * 63 31449599 15724768+ 7 HPFS/NTFS/exFAT
/dev/sda2 31449600 465317999 216934200 7 HPFS/NTFS/exFAT
/dev/sda3 465318000 486289439 10485720 83 Linux
/dev/sda4 486291456 488396799 1052672 82 Linux swap
root@PartedMagic:~#

From the grub rescue prompt:

error: unknown filesystem.
grub rescue> set
prefix=(hd0,msdos3)/boot/grub
root=hd0,msdos3
grub rescue> insmod normal
error: unknown filesystem.
grub rescue> ls /boot
error: unknown filesystem.
grub rescue> insmod linux
error: unknown filesystem.
grub rescue> set prefix=(hd0,3)/boot/grub
grub rescue> set
prefix=(hd0,3)/boot/grub
root=hd0,msdos3
grub rescue> set root=(hd0,3)
grub rescue> set
prefix=(hd0,3)/boot/grub
root=hd0,3
grub rescue> insmod normal
error: unknown filesystem.
grub rescue> ls /boot
error: unknown filesystem.
grub rescue> insmod linux
error: unknown filesystem.
grub rescue> insmod (hd0,3)/usr/lib/grub/i386-pc/normal.mod
error: unknown filesystem.

Using PartedMagic -

/media/sda3/boot/grub contains
normal.mod [104.2KB]
/media/sda3/boot/ contains [among others]
config-3.0.0-12-generic
initrd.img-3.0.0-12-generic
System.map-3.0.0-12-generic
vmlinuz-3.0.0-12-generic

Assistance in resolving this issue would be appreciated.

Tranas Spietis <tranas>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by tranas (Submitted the item)
  • -unavailable- added by tranas
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 03 Jun 2012 12:51:38 PM UTCphcoderStatusNone=>Invalid
      Open/ClosedOpen=>Closed
    Wed 29 Feb 2012 02:59:20 PM UTCtranasCarbon-Copy-=>Added tranas

    Back to the top


    Powered by Savane 3.1-cleanup1