bugGnash - The GNU Flash player - Bugs: bug #32588, Some YouTube movies use AVM2...

 
 

bug #32588: Some YouTube movies use AVM2 watermark file

Submitted by:  Rob Savoye <rsavoye>
Submitted on:  Thu 24 Feb 2011 05:11:10 PM UTC  
 
Category: avm2Severity: 3 - Normal
Release: masterStatus: In Progress
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 24 Feb 2011 05:11:10 PM UTC, original submission:

At least in the US, some of the commercial movies available freely load a "watermark*.swf" file, which is AVM2. This produces the infamous "error occurred": message which looked like the old issue with cookie. I verified that cookies were working 100% correctly. The big difference is that along with the error message, Gnash displays the spinning wheel forever...

So this isn't exactly a Gnash bug, as it doesn't handle AVM2. A bug report has been sent to the YouTube developers, who have been helpful to make sure they only serve up AVM1 files when Gnash is the User agent. This bug is just to document the problem so it doesn't get lost.

Rob Savoye <rsavoye>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rsavoye (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup