bugGNU nano - Bugs: bug #30786, when saving, nano wipes out...

 
 

bug #30786: when saving, nano wipes out existing data when device is full

Submitted by:  None
Submitted on:  Mon 16 Aug 2010 09:41:33 AM UTC  
 
Severity:  4 - Important Status:  Duplicate
Assigned to:  Benno Schulenberg <bens> Open/Closed:  Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 01 May 2018 05:46:55 PM UTC, comment #5:

Closing, because a duplicate of bug #36864.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Thu 01 Mar 2018 06:32:47 PM UTC, comment #4:

The original report is a bit strange: it says that for saving the config file, ^O S was used. I don't think "S" was the name of the config file, so probably it was a response to a yes-no question. There is no locale where "S" is the letter for "No"; there are only locales (Spanish, Catalan, Portuguese, and similar) where "S" is the letter for "Yes" (Sí). So what the original poster probably did was: ^X S <Enter>. (Because if he used ^O <Enter>, he gets the error message ("No space") and then, in order to exit from nano, he would have to use ^X N -- never any S.)

If anyone has additional information, preferably a reproduction recipe. please post the info to bug #36864.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 14 Jun 2014 08:52:18 PM UTC, comment #3:

This is a duplicate of bug #36864.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 21 Aug 2010 08:34:44 AM UTC, comment #2:

Hi, I'm the original poster. If there is something (reasonable) I could do to test / reproduce the issue for you, let me know.

(I would have logged in, but even after registering and following the confirmation link via email it won't let me, saying: "Error Account Pending." Lovely.)

Anonymous
Tue 17 Aug 2010 05:34:24 PM UTC, comment #1:

Hello,

Hmm, well since this is submitted by None I'm worried I won't be able to get any detailed reproduction info, but if the OP comes back to check on this bug if (s)he could mention whether nano thought the write was successful or not that would be helpful. Actually 2.0.9 added a fix specifically for the case of a full filesystem, but perhaps the writeout (^O) code is doing something different from the exit-time saving code. Thanks for the report either way and apologies for any hardship this may have caused you.

Chris Allegretta <astyanax>
Project Administrator
Mon 16 Aug 2010 09:41:33 AM UTC, original submission:

Recently I logged into a system to see what had gone wrong with it. I assumed it was a missing setting in a config file I'd forgotten to add.

Unbeknownst to me, the disk/device was actually full, and when I went to save (CTRL+O, S) the config file, it wiped out all the existing data(!!!). The file was still there, but at 0 bytes in size.

FWIW, this is on CentOS 5.5 running 2.0.9:

$ nano -V
GNU nano version 2.0.9 (compiled 10:27:02, Mar 30 2009)
(C) 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007
Free Software Foundation, Inc.
Email: -email is unavailable- Web: http://www.nano-editor.org/
Compiled options: --disable-wrapping-as-root --enable-color --enable-extra --enable-multibuffer --enable-nanorc --enable-utf8

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Posted a comment)
  • -email is unavailable- added by astyanax (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-05-01 bens Open/ClosedOpen => Closed
    2018-03-01 bens Assigned toastyanax => bens
        SummaryWhen saving, nano wipes out existing data when device is full => when saving, nano wipes out existing data when device is full
    2014-06-14 bens StatusNone => Duplicate
    2010-08-17 astyanax Severity3 - Normal => 4 - Important
        Assigned toNone => astyanax

    Back to the top


    Powered by Savane 3.3