bugLibreDWG - Bugs: bug #28681, Dwg_Object_Ref's pointing to wrong...

 
 

bug #28681: Dwg_Object_Ref's pointing to wrong objects

Submitted by:  Rodrigo Rodrigues da Silva <pitanga>
Submitted on:  Tue 19 Jan 2010 06:31:06 AM UTC  
 
Category: NoneSeverity: 5 - Blocker
Item Group: NoneStatus: Need Info
Privacy: PublicAssigned to: LibreDWG developers <libredwg-dev>
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 19 Jan 2010 06:31:06 AM UTC, original submission:

During v.in.redwg GRASS module I found out that some Object_Ref's are pointing to the wrong objects/entites, eg. LAYER_CONTROL objects' layer arrays work fine, with Object_Refs pointing to all layers within the document (AFAIK, I'm not sure if there's only one LAYER_CONTROL per file); but entities' layer Object_Refs point to "random" objects. I found one of them pointing to a object with code = 500 (one of those with non-fixed codes).

I'll provide more info as soon as I get back to work (and maybe publish) the v.in.redwg module. Anyway, please try to play around with these nasty object pointers. We should redesign/refactor this feature sometime.

Rodrigo Rodrigues da Silva <pitanga>
Project AdministratorIn charge of this item.

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by pitanga (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup