bugfindutils - Bugs: bug #28490, find v4.5.5 dies with an assertion...

 
 

bug #28490: find v4.5.5 dies with an assertion failure

Submitted by:  Kenneth Nellis <nellisks>
Submitted on:  Tue 05 Jan 2010 06:28:59 PM UTC  
 
Category:  find Severity:  3 - Normal
Item Group:  Wrong result Status:  Duplicate
Privacy:  Public Assigned to:  James Youngman <jay>
Originator Name:  Kenneth Nellis Open/Closed:  Closed
Release:  4.5.4 Fixed Release:  4.5.8

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 28 Apr 2010 01:33:18 PM UTC, comment #6: 

find 4.5.8 finally made it into the Cygwin distribution and it fixes my problem. Thanx! --Ken

Kenneth Nellis <nellisks>
Sun 11 Apr 2010 12:02:11 PM UTC, comment #5: 

#27213 was fixed in findutils-4.5.8, so I will also mark this as closed.

James Youngman <jay>
Project AdministratorIn charge of this item.
Tue 06 Apr 2010 06:03:40 PM UTC, comment #4: 

OK, thanks for the feeback.

James Youngman <jay>
Project AdministratorIn charge of this item.
Tue 06 Apr 2010 12:51:15 PM UTC, comment #3: 

I won't be testing the patch. I'm fine with Martin's suggestion that it may be a dupe. --Ken

Kenneth Nellis <nellisks>
Sun 04 Apr 2010 09:28:19 PM UTC, comment #2: 

Unless you tell me it's not a dupe, I'm going to assume Martin is correct.

James Youngman <jay>
Project AdministratorIn charge of this item.
Wed 03 Feb 2010 08:56:57 AM UTC, comment #1: 

Duplicate of or related to bug 27213?
Does the patch there help solve your issue?

Martin von Gagern <gagern>
Tue 05 Jan 2010 06:28:59 PM UTC, original submission:  

The “find” command died with a failed assertion message. I copy the failed command and version information follow.

—Ken Nellis, ACS

Cygwin> find -type f | wc -l
assertion "ent->fts_info == FTS_NSOK || state.type != 0" failed: file "/usr/src/findutils-4.5.5-1/src/findutils-4.5.5/find/ftsfind.c", line 477, function: consider_visiting
0
Cygwin> find --version
find (GNU findutils) 4.5.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Eric B. Decker, James Youngman, and Kevin Dalley.
Built using GNU gnulib version 533b27747fe3d0d67f727d4d7ba6c97f8a5b4060
Features enabled: D_TYPE O_NOFOLLOW(enabled) LEAF_OPTIMISATION FTS(FTS_CWDFD) CBO(level=2)
Cygwin>

Kenneth Nellis <nellisks>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jay (Posted a comment)
  • -email is unavailable- added by gagern (Posted a comment)
  • -email is unavailable- added by nellisks (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2010-04-11 jay Open/ClosedOpen => Closed
        Fixed ReleaseNone => 4.5.8
    2010-04-06 jay StatusNeed Info => Duplicate
    2010-04-04 jay StatusNone => Need Info
        Assigned toNone => jay
    2010-02-03 gagern Carbon-CopyRemoved -email is unavailable- => -
    2010-02-03 gagern Carbon-Copy- => Added martin.vgagern@gmx.net

    Back to the top


    Powered by Savane 3.5