buglibffcall - foreign function call libraries - Bugs: bug #22086, callback library fails on Mac OS...

 
 

bug #22086: callback library fails on Mac OS 10.4.4

Submitted by:  Sam Steingold <sds>
Submitted on:  Tue 22 Jan 2008 08:27:40 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  regression Status:  Wont Fix
Privacy:  Public Assigned to:  Bruno Haible <haible>
Open/Closed:  Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 03 Jan 2017 04:28:20 AM UTC, comment #1:

Mac OS X 10.4 on PowerPC (released in 2005) is too old to be supported.

Bruno Haible <haible>
Project AdministratorIn charge of this item.
Tue 22 Jan 2008 08:27:40 PM UTC, original submission:

http://sourceforge.net/tracker/index.php?func=detail&aid=1422728&group_id=1355&atid=101355
Building CLISP 2.38, building on Mac OS 10.4.4 with GCC 4.0.0, the FFI
does not get configured because the callback library's unit tests fail:
only
if these pass will the FFI be built.

Specifically the minitests fail:

Melchizedek (0)% ./minitests
void f(void):
void f(void):
int f(void):->99
int f(void):->99
int f(int):(1)->2
int f(int):(1)->2
int f(2*int):(1,2)->3
int f(2*int):(1,2)->3
int f(4*int):(1,2,3,4)->10
int f(4*int):(1,2,3,4)->10
int f(8*int):(1,2,3,4,5,6,7,8)->36
int f(8*int):(1,2,3,4,5,6,7,8)->36
int f(16*int):(1,2,3,4,5,6,7,8,9,11,12,13,14,15,16,17)->143
zsh: illegal hardware instruction ./minitests
Melchizedek (132)%

also:

i have the same problem on a Powerbook G4 500mhz with OS X 10.4.9. Tried
to build it via pkgsrc lang/clisp.

For more information look here please:
http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=36101

blueAnt:~ ibn$ gcc --version
powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5247)
Copyright (C) 2005 Free Software Foundation, Inc.

Sam Steingold <sds>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Posted a comment)
  • -email is unavailable- added by sds (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-01-03 haible StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2009-04-28 sds Item GroupNone => regression

    Back to the top


    Powered by Savane 3.3